Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Set Up Wake on LAN

  1. #11
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,833
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Set Up Wake on LAN

    Quote Originally Posted by Kain000 View Post

    So I'm not sure what I'm not giving the program that it needs to work, espacially because the website from my last post works from the net and doesnt require any more info than the public IP, port number, and mac address.
    What is it doing that wake on lan is not???
    this is really driving me nuts because it seems like it should work.
    Sorry about the mis-information. I don't think the router mac is used. I had wrote that from memory. I guess my memory fails me.

    The linked site you are using also requires the subnet. I think this is giving my trouble.

    One thing to keep in mind, is how your machine is shutdown. When my backend shutsdown via ACPI wake command, the WOL does not work.

    This is a big bummer for me, since this is the machine I want to wake, in case I want to schedule, or watch a recording and the machine is off.

    I am not sure if wakeonlan is designed to work outside the network.

    I see the utility at ichu.net modify the information to a broadcast address.

    I could not get my system to wake at ichu.net. I did however get it to wake at http://www.dslreports.com/wakeup.

    Still working on a solution from my phone, and issue with ACPI wake.

    EDIT: Found this in the README for wakeonlan

    3. How is it implemented here ?

    The scripts takes 2 arguments, the MAC-address of the NIC, and an IP
    address. The IP-address is tricky :

    For a NIC on your local subnet, use the broadcast-address of this subnet.
    (e.g. subnet 192.168.10.0 with netmask 255.255.255.0, use 192.168.10.255)

    For waking up a PC on a network behind one or more routers, some tricks must
    be used. When the routers forward directed subnet broadcasts, it is possible
    to use the broadcast address of the destination network. The problem is that
    many routers dont forward broadcast packets, so the packet will never arrive
    at the network.

    It is possible to send the packet to the remote net however, by sending it
    to the IP address of another host on that network that's alive at that
    moment. The remote hosts will probably ignore the packet, but it has been
    seen by the listening NIC that's also on the same subnet, and it will turn
    on the computer... Feel free to experiment on this.
    Last edited by volkswagner; September 12th, 2008 at 12:26 AM.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  2. #12
    Join Date
    Feb 2007
    Location
    New Jersey, USA
    Beans
    318

    Re: Set Up Wake on LAN

    From where are you sending the signal using wakeonlan? Is it at a school that possibly restricts outgoing information and religates it to things like http, pop, smpt, etc. You might try it from a friend's house nearby.

    If you are entering the same IP address and MAC address at dslreports.com/wakeup that are you using wakeonlan - then I can't think of any obsticle other than the firewall of the network you're currently behind.
    Disclaimer: All of my advice is guaranteed without exception to work. If you find my advice unsatisfactory, you didn't do it right.

  3. #13
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,833
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Set Up Wake on LAN

    I thought I had an issue due to changing the subnet mask in the router settings, after setting up wakeonlan script. I made this change due to info found at dsl site mentioned earlier.

    After editing the script wakeonlan to reflect subnet=255.255.255.128 to match my current router setting. Local wake on lan failed and I get an "invalid argument at line 126".

    here is line 126 from /usr/bin/wakeonlan.
    Code:
    send(S, $pkt, 0, $them) or die "send : $!";



    Still can only get it to wake outside lan via web utitlity, not any external programs.

    Wonder if it is a router limitation. I would love to know what the web utility does differently.

    I guess I'll need to clutch the online utility. I hope I can get acpi wake and wakeonlan to play.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  4. #14
    Join Date
    Feb 2007
    Location
    New Jersey, USA
    Beans
    318

    Re: Set Up Wake on LAN

    You could also try the program etherwake, which is in the repositories.
    Disclaimer: All of my advice is guaranteed without exception to work. If you find my advice unsatisfactory, you didn't do it right.

  5. #15
    Join Date
    May 2008
    Location
    Camp Pendleton, CA
    Beans
    348
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Set Up Wake on LAN

    Quote Originally Posted by volkswagner View Post
    I thought I had an issue due to changing the subnet mask in the router settings, after setting up wakeonlan script. I made this change due to info found at dsl site mentioned earlier.

    After editing the script wakeonlan to reflect subnet=255.255.255.128 to match my current router setting. Local wake on lan failed and I get an "invalid argument at line 126".

    here is line 126 from /usr/bin/wakeonlan.
    Code:
    send(S, $pkt, 0, $them) or die "send : $!";



    Still can only get it to wake outside lan via web utitlity, not any external programs.

    Wonder if it is a router limitation. I would love to know what the web utility does differently.

    I guess I'll need to clutch the online utility. I hope I can get acpi wake and wakeonlan to play.
    Hummm,
    what is the exact command you issue to wake on lan?
    it should be (when logged onto your home network) just the mac address of your computers hardware. wake on lan will push this magic packet to everything on the network and everyone but the target computer will discard the packet. Just make sure you have a (usually port #9) port open and forwarded to your target under port mapping or NAT routing or w/e the tab is in your router's set up app.
    By the way what router are you using?
    also how are you shutting down your computer? I dont suppose this could be the problem as you've gotten the packet form the internet to work, thus passing both the NAT firewall and shutdown tests. The only thing I can think of doing From inside the network is to try these. (insert correct mac address and or ip/port)

    Code:
    wakeonlan 00:00:00:00:00:00
    or
    Code:
    wakeonlan -i 23.45.67.891 00:00:00:00:00:00
    your routers public ip and the mac of your target's network card
    or
    Code:
    wakeonlan -i 23.45.67.891 -p 9 00:00:00:00:00:00
    your ip, and port forwarded (guessing it's port #9) and mac address.

    Technically from inside your network you should get away with just using the first example, as wakeonlan should, if no network address is specified, push the magic packet to the entire subnet of the network (every computer on your lan) and if connected the computer that it's for will hear it and wake up.

    Try em and let me know
    -sean

  6. #16
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,833
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Set Up Wake on LAN

    Quote Originally Posted by Kain000 View Post
    Hummm,
    what is the exact command you issue to wake on lan?
    it should be (when logged onto your home network) just the mac address of your computers hardware. wake on lan will push this magic packet to everything on the network and everyone but the target computer will discard the packet. Just make sure you have a (usually port #9) port open and forwarded to your target under port mapping or NAT routing or w/e the tab is in your router's set up app.
    By the way what router are you using?
    also how are you shutting down your computer? I dont suppose this could be the problem as you've gotten the packet form the internet to work, thus passing both the NAT firewall and shutdown tests. The only thing I can think of doing From inside the network is to try these. (insert correct mac address and or ip/port)

    Code:
    wakeonlan 00:00:00:00:00:00
    -sean
    Yes, when inside my lan, I use the mac address of the target pc.

    I noticed wakeonlan displayed

    Code:
    Sending magic packet to 255.255.255.255:9 with 00:xx:xx:xx:xx:xx
    This works. Odd thing is my subnet is 255.255.255.128. If I change my subnet in wakeonlan script, that is when I get the error and wakonlan fails.

    Router-Linksys WRT54G ver. 8, firmware ver. 1.02.0
    I shut down using sudo halt and all is ok. When ACPI wake command sets the shutdown, wakeonlan Fails.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  7. #17
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,833
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Set Up Wake on LAN

    OK, got it working.

    I am using microWow from google-code.

    Via my Nokia N95 my settings are as follows

    Name-AnyName
    Network:
    Host-volkswagner.com
    Port-9
    Mac-my:ma:ca:dd:re:ss
    Packets to send-1

    It works both via my wifi (lan) and GPRS connection (outside lan).

    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  8. #18
    Join Date
    May 2008
    Location
    Camp Pendleton, CA
    Beans
    348
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Set Up Wake on LAN

    Excelent my friend! so this microWOW is for any os? I looked on the download page and cannot find a specific os. How'd you get it on your phone?

  9. #19
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,833
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Set Up Wake on LAN

    Quote Originally Posted by Kain000 View Post
    Excelent my friend! so this microWOW is for any os? I looked on the download page and cannot find a specific os. How'd you get it on your phone?
    It is a MIDlet. It is a java app for embeded devices such as any mobile phone that can run java apps.

    I just downloaded it and installed all via my phone.

    This was my ultimate goal, since I can easily wake my machine from home and anywhere there is cell service.

    I should also mention dyndns is resolving my host name and dynamic ip.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  10. #20
    Join Date
    Sep 2007
    Location
    North Ft. Myers, FL USA
    Beans
    477
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Set Up Wake on LAN

    Don't you have to edit IP tables to allow port 9 through your firewall on Ubuntu?

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •