Page 13 of 16 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 158

Thread: Can not get wireless card to even show up

  1. #121
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can not get wireless card to even show up

    According to some googling, the black screen issue seems to be a known problem that affects certain VAIO laptops with your type of graphics card. We should be able to fix it using the information in this thread.

    But first, you'll need to have Ubuntu 10.04 or 10.10 installed. To do that, your best bet is to download the alternative installer CD, which will allow you to run the installer in text-only mode and avoid any issues with a black screen.

    Once you have the system installed, boot to it. When you get to a black screen, press control-alt-F2, which should hopefully bring you to a command prompt. There, log in with your username and password. Then type:

    Code:
    sudo nano /etc/X11/xorg.conf
    A blank file should open. Put these lines in it:
    Code:
    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection
    Save the file by pressing control-O (the letter O, not the number zero), then reboot your computer. It should work graphically this time, albeit with low resolution. Once you've gotten this far, let me know and we can work on fixing the graphics so they work in full resolution (that should be easy, since with this more recent version of Ubuntu, your wireless should work out-of-the-box).
    Last edited by pytheas22; October 19th, 2010 at 10:30 PM.

  2. #122
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    Will try, thank you do much for your time
    Last edited by khoi0107; October 20th, 2010 at 12:58 AM.

  3. #123
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    I installed 10.10 via alternate CD as u said. I booted ubuntu, it went black screen and I heard a drum beat sound (It should be the login screen i guess). Tried to press ctrl+alt+f2 many times but nothing happened, it's still black for me .

    does it work if I use another LCD monitor, plugin VGA port to display it?

  4. #124
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can not get wireless card to even show up

    Sorry that didn't work quite as expected. It's good that you hear the drumbeat sound--that means Ubuntu is loading without a problem--but apparently there's an issue preventing it from displaying on the screen correctly.

    It might work with an external monitor. That's worth a try if you have one easily accessible.

    If not, or if an external monitor doesn't help, you can make the change you need by booting your computer to a live Ubuntu CD or USB (you can use any version of Ubuntu that you are able to boot to). Once in the live environment, open a file browser with root privileges by typing in a terminal:

    Code:
    sudo nautilus
    A window will open. In the window, navigate to the Ubuntu partition of your internal hard drive by clicking its name in the left-hand section of the window (if it's not obvious which entry in the left-hand menu is the correct one for your Ubuntu partition, you may have to experiment to find it; unfortunately it's impossible for me to know exactly what it will be called). Note that you should not navigate to the location "/" of the live file system. Instead, you will be looking for the root directory of the Linux partition of your computer's hard drive, which will be something like /media/9a278276-edfb-4c26-afba-1f73637ddf4c (again, I can't know the exact path without having access to your computer).

    Once you're in the root directory of your internal hard drive, you should see a folder called "etc." Inside "etc" should be another folder called "X11." Open X11, then right-click and select Create Document>Empty File. Name the file "xorg.conf" (without the quotation marks). Double-click the file to open it in an editor, then enter the lines:
    Code:
    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection
    Save and close the file, then reboot your computer. It should now load with the failsafe graphics driver, and hopefully display a screen.

    Sorry this is proving to be more complicated than I'd anticipated, but thanks so much for your patience.

  5. #125
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    should've tried before asking u.I dont have to use live CD, It works with another LCD monitor. I got wireless and everything.
    So i tried to edit the file like u to get its on my primary screen too.
    I used
    sudo nano /etc/X11/xorg.conf

    and put the content in like u said. But when i pressed ctrl+o and enter it gave me this
    [error writing /etc/x11/xorg.conf: no such file or directory]

    I looked up in Filesystem/etc too but there isnt any "x11" folder
    Last edited by khoi0107; October 21st, 2010 at 06:38 AM.

  6. #126
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    aw, sry i screwed up again. I used "additional drivers", hope I could find something to do with my graphic card and I did. It said I need Nvidia accelerator driver, i activated it and restart

    Now I get a "single-color "no-effect" (sry for my English, i mean it's much simplier)pink screen with ubuntu loading (4 dots thingy), some text loading and everything goes pink screen and stay still, same like black screen but now even external monitor cant work as well

    If u can help me a way to set up the laptop screen by using the external monitor i will gladly install 10.10 again to have it work on the external monitor again.

    Thank you very much

    PS: i think the problem is the widescreen. I have had a lot of problems dealing with applications&games can't run in 16-9 mode.

  7. #127
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can not get wireless card to even show up

    Good to hear that the external monitor works. FYI, you got the "[error writing /etc/x11/xorg.conf: no such file or directory]" message because the path has to be /etc/X11/xorg.conf, with an uppercase X, not x. In Linux case matters, so X is totally different from x.

    But we don't need to worry about editing the xorg.conf file anymore, since you can get the screen to display on the external monitor. That should be sufficient for installing an updated graphics driver that should solve the whole problem.

    To do that, reinstall Ubuntu 10.10 and attach your external monitor. Then follow these steps (which are based mostly on what I'm reading here):

    1. first, we'll disable "kernel mode setting," which can cause graphics problems, by editing your grub configuration. Open a terminal and type:
    Code:
    sudo nano /etc/grub/default
    A file will open. Look for the line that reads:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Modify that line so it says:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
    Finally, type:
    Code:
    sudo update-grub
    to make this change permanent.

    2. reboot the computer so that you're running without kernel mode setting.

    3. now we need to install the proprietary nvidia Linux driver. The thread that I've referenced says that the latest version of the nvidia driver doesn't work, but an older one does. This would explain why the driver that you installed on your own previously didn't solve the problem.

    We can download an older version of the driver from nvidia's site and install it manually (for this step, I've referred a little to this thread). First, download the source either from here (if you're using 32-bit Ubuntu) or here (for 64-bit). Save the downloaded file to your desktop.

    Next, open a terminal and type this command (to install a compiler and other tools that you will need to build the nvidia driver):
    Code:
    sudo apt-get install build-essential
    Next, press control-alt-F2, which should take you to a fullscreen terminal. There, log in and run these commands:
    Code:
    sudo /etc/init.d/gdm stop
    cd ~/Desktop
    sudo bash NVIDIA*run
    Follow the instructions on the screen for compiling the nvidia driver. Once it's all done, reboot by typing "sudo reboot".

    After the reboot, with any luck, your display will be working. Please let me know.

  8. #128
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    i reinstalled it
    The sudo nano I gave me this

    I don't see aything in the file to edit, its like a im making a new file here. There's only grub.d in etc, and grub is in boot i think. I did try sudo nano /boot/grub/default but the result was the same
    btw, sry abt the x and X thingy, Im such a noob
    Last edited by khoi0107; October 21st, 2010 at 11:48 AM.

  9. #129
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can not get wireless card to even show up

    So sorry--it was a mistake on my part! The file to edit is /etc/default/grub/, not /etc/grub/default. So:
    Code:
    sudo nano /etc/default/grub
    will open it up for you. Sorry for not catching that. Good thinking trying to find it in /etc/grub.d but unfortunately that's not quite it!
    btw, sry abt the x and X thingy, Im such a noob
    Don't worry, we've all done that before

  10. #130
    Join Date
    Oct 2010
    Beans
    21

    Re: Can not get wireless card to even show up

    awesome, i got the screen after the "nomodeset" and reboot. I installed NVIDIA, but the final problem is now my ubuntu (rebooted after install Nvidia) always starts up with a tty1 console. As I googled i used ctrl+atl+f7 to return to graphical screen but it stuck at checking sensor or battery. Seems like this guy had the same problem http://ubuntuforums.org/showthread.php?t=1495722

    Do i have to... like "start" the /etc/init.d/gdm after I stopped it?

    Thank you so much for time
    Last edited by khoi0107; October 23rd, 2010 at 04:05 PM.

Page 13 of 16 FirstFirst ... 31112131415 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •