Results 1 to 5 of 5

Thread: Touchpad Sensitivity

  1. #1
    Join Date
    Mar 2006
    Location
    Suffolk County, NY
    Beans
    158
    Distro
    Ubuntu 8.04 Hardy Heron

    Touchpad Sensitivity

    How can I make the touchpad sensitivity higher in Ubuntu 8.04 on a Dell Latitude D630? Thanks.
    chown us:us -R /AllYourBase
    Quote Originally Posted by Black Razor View Post
    It takes an intelligent open minded individual to come from windows to Linux.

  2. #2
    Join Date
    Apr 2006
    Location
    Utah, USA
    Beans
    521
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Touchpad Sensitivity

    If you haven't already, install gsynaptics, which requires you to set a line in your xorg.conf file for "SHMConfig". Follow the guide on Synaptics Touchpad, which includes a bunch more info.

    On my Dell Inspiron 1420 the gui tool barely changes sensitivity, and I had to set additional minspeed, and maxspeed stuff in xorg. Here's what my section for the touchpad looks like.

    Code:
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"	"/dev/psaux"
    	Option		"Protocol"	"auto-dev"
    	Option		"HorizEdgeScroll"	"50"
    #	Option 		"HorizScrollDelta" 	"0"
    	Option		"MinSpeed" 	"0.7"
    	Option		"MaxSpeed" 	"0.7"
    #	Option		"AccelFactor"	"0.0010"
    	Option		"SHMConfig"	"true"
    EndSection
    Not sure what the two commented lines were ever for. If you use any of those you might have to play with the values to get them to your liking, and you'll have to restart X11 each time.

  3. #3
    Join Date
    Mar 2006
    Location
    Suffolk County, NY
    Beans
    158
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Touchpad Sensitivity

    Thanks. I'll look into that.
    I know
    Code:
    Option 		"HorizScrollDelta" 	"0"
    If you uncommented it, you wouldn't be able to use your touchpad's outer edge to scroll horizontal scrollbars anymore. I hate that feature, so I have horizontal, and vertical scrolling turned off. I also have "MaxTapTime" set to "0", because I hate tap to click. My palm tends to hit the touchpad when I type.Here is my current touchpad configuration:
    Code:
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"	"/dev/psaux"
    	Option		"Protocol"	"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    	Option		"MaxTapTime"		"0"
    	Option		"VertScrollDelta"	"0"
    chown us:us -R /AllYourBase
    Quote Originally Posted by Black Razor View Post
    It takes an intelligent open minded individual to come from windows to Linux.

  4. #4
    Join Date
    Apr 2006
    Location
    Utah, USA
    Beans
    521
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Touchpad Sensitivity

    I hate tapping too, I've been able to turn it off in the GUI, oddly enough it has to be off under both mouse and touchpad settings. Glad I didn't have to turn it off in X because my wife likes it on for her user.
    Guess that explains why I commented the scrolling line, since I like that feature turned on. Just noticed the syndaemon in that guide, I should try that since I sometimes accidentally bump scrolling while typing.

  5. #5
    Join Date
    Mar 2006
    Location
    Suffolk County, NY
    Beans
    158
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Touchpad Sensitivity

    Well thanks for the advice before about what to do with the toucpad sensitivity. I'll attempt it once I get home.
    chown us:us -R /AllYourBase
    Quote Originally Posted by Black Razor View Post
    It takes an intelligent open minded individual to come from windows to Linux.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •