Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: HOWTO: WPA2 with NETGEAR WPN111

  1. #21
    Join Date
    Apr 2010
    Beans
    2

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Do you have 32 or 64 bit installed?

    Didn't seem to work for me... Although I did get the same messages
    Last edited by Areleos; April 5th, 2010 at 05:02 PM.

  2. #22
    Join Date
    Feb 2010
    Beans
    6

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Your how to works for me on Ubuntu 9.10 Karmic.

    However, when I restart (reboot) the system, the led stays lit (blinking) and the WPN111 does not work anymore.

    My solution for this is:

    Shutdown the system and restart (to unload WPN111 and reload WPN111)

    OR

    unplug the WPN111 and plug it back in
    and
    use ndisgtk to remove and reinstall the driver


    Does anyone knows a better solution for this problem?

  3. #23
    Join Date
    Jul 2008
    Location
    North Carolina
    Beans
    478
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Quote Originally Posted by Areleos View Post
    Do you have 32 or 64 bit installed?

    Didn't seem to work for me... Although I did get the same messages
    I had 32 bit installed -- NETGEAR has not released a 64 bit of the WPN111 driver, much to the chagrin of 64 bit Vista users.


    Quote Originally Posted by kmarien View Post
    Your how to works for me on Ubuntu 9.10 Karmic.

    However, when I restart (reboot) the system, the led stays lit (blinking) and the WPN111 does not work anymore.

    My solution for this is:

    Shutdown the system and restart (to unload WPN111 and reload WPN111)

    OR

    unplug the WPN111 and plug it back in
    and
    use ndisgtk to remove and reinstall the driver


    Does anyone knows a better solution for this problem?
    I don't know of a better solution, this same issue occurred for me when I used this wireless card. What I always did was, as the computer was restarting, before it booted into Ubuntu, I unplugged and replugged the adapter. Not sure what the issue was.
    Good judgment comes from experience, and often experience comes from bad judgment.

  4. #24
    Join Date
    Apr 2010
    Beans
    2

    Re: HOWTO: WPA2 with NETGEAR WPN111

    I tried it with both and it didn't work either time... Might be that the encryption is WAP.

  5. #25
    Join Date
    Jul 2008
    Location
    North Carolina
    Beans
    478
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Not sure, I only had a WPA2 network to test it on, and it was tricky. I don't have the adapter anymore to test with, sorry, but if you find any method that works for you in the future, I'd like to hear it
    Good judgment comes from experience, and often experience comes from bad judgment.

  6. #26
    Join Date
    Jun 2010
    Location
    IL, USA
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Quote Originally Posted by itsjareds View Post
    Alright, I was finally able to get a new adapter, a Rosewill RNX-EasyN1. I've got that driver installed now and I should hopefully have a stable connection now. I still have the WPN111, so if anybody needs me to do testing for it, I will.

    Thanks for all the support shown so far, I (and I'm sure many others) really appreciate it.
    i do appreciate it

    but i have a problem, i currently have 2 usb wireless adapters: the wpn111 and the rnx-easyn1. i followed your instructions to install the wpn111 and it worked, but i never got over the problem of the dropping connections.

    that's when i decided to buy the rnx-easyn1, i followed the same instructions, just replacing the driver files, but i keep getting an error saying that the driver was invalid.

    i used the driver that comes in the CD, so what could be wrong then?

    would you mind elaborating on how did you manage to install the rnx-easyn1? or maybe post the driver files that you used.

    thanks.
    Last edited by eliseo.arias; June 13th, 2010 at 02:54 PM.

  7. #27
    Join Date
    Jul 2008
    Location
    North Carolina
    Beans
    478
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Since Karmic, using the RNX-EasyN1 has been much simpler. The driver is included by default. Now all you have to do to enable the driver is follow these steps:

    Code:
    sudo rmmod rt2800usb
    sudo modprobe rt2870sta
    echo "blacklist rt2800usb" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Then you may have to unplug and re-plug your adapter to allow the adapter to scan for networks. The last step I listed was to add rt2800usb to the module blacklist -- it seems that r2800usb was "overpowering" the driver/module that the RNX-EasyN1 needed, so disabling that one allows the correct driver to be used when rebooting.
    Last edited by itsjareds; June 14th, 2010 at 01:54 AM.
    Good judgment comes from experience, and often experience comes from bad judgment.

  8. #28
    Join Date
    Jun 2010
    Location
    IL, USA
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    oh so the drivers come with ubuntu already? i didn't know that...

    i did a clean install and followed your steps, they worked to make the usb card detect the networks, but i was unable to connect to my home wireless. here's the output of each command:


    Code:
    $ sudo rmmod rt2800usb
    ERROR: Module rt2800usb does not exist in /proc/modules
    $ sudo modprobe rt2870sta
    $ echo "blacklist rt2800usb" | sudo tee -a /etc/modprobe.d/blacklist.conf 
    blacklist rt2800usb
    $
    after this the card was able to detect the networks. yet when i tried to connect to my network it didn't connect. it won't give me an error message either, it'll just spin for like a minute or two and then ask for my password again, if i enter it again it'll spin again and ask for it again, and so on. i use wpa2.

    i also tried restarting the pc and even connecting to an unsecure network with no luck.

    i'm no linux expert but i've seen people use dmesg, here's the output of mine:
    Code:
    $ dmesg | grep rt28
    [   13.884724] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
    [   13.928255] usbcore: registered new interface driver rt2870
    $
    any idea what the problem could be?

  9. #29
    Join Date
    Jul 2008
    Location
    North Carolina
    Beans
    478
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: WPA2 with NETGEAR WPN111

    Yeah, the drivers come in Ubuntu by default because Ralink (the maker of the chipset in our adapter) released a Linux version of the driver with configuration files and everything. There is not a Linux driver for the WPN111 so we had to rely on ndiswrapper, which was basically a way to use Windows network driver binaries in Linux.

    I just always have to unplug and re-plug the adapter before I try to connect to any networks. I'm not sure what the issue is but that is quick and simple. I only have to do it that one time.
    Last edited by itsjareds; June 14th, 2010 at 04:58 AM.
    Good judgment comes from experience, and often experience comes from bad judgment.

  10. #30
    Join Date
    Sep 2008
    Location
    Earth
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: HOWTO: WPA2 with NETGEAR WPN111

    well! i followed these instructions in 10.04 and they showed no evidence of working, but then i read farther into the thread and found everybody talking about unplugging and replugging the adapter, so - with little hope, as i've tried to get this thing working many times and the one time i succeeded, a restart killed it once and for all - i unplugged the adapter and plugged it back in, then uninstalled and reinstalled the driver, and ta-dah! it works.

    thanks a bunch everybody.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •