Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Sound from speaker and headphone - can't disable speaker

  1. #1
    Join Date
    Aug 2008
    Beans
    6

    Sound from speaker and headphone - can't disable speaker

    Sorry for the blast....
    Card identified as ICH5
    Chipset SigmaTel STAC9758.59

    Cannot seem to disable labtop speaker, so sound plays simultaneously from speaker and headphone. Tried ALSA Mixer and PCM, but can't seem to find the magic incantation to disable the speakers. Off-hook option not visible in ALSA Mixer.

    Laptop is uncertified Gateway M675, which seems to defy all the rules thus far.
    Thanks in advance for any suggestions.

  2. #2
    Join Date
    Aug 2008
    Beans
    178

    Re: Sound from speaker and headphone - can't disable speaker

    Try going to the terminal (if you didn't already) and type

    alsamixer

    It should bring up alsamixer within the terminal. Scroll to the right and the left, and up and down to toggle percentage. You will be able to turn the speaker (possibly INTERNAL speaker?? not pc speaker) to 0, and front speaker up. try experimenting with the different vaules in alsamixer.

  3. #3
    Join Date
    Aug 2008
    Beans
    6

    Re: Sound from speaker and headphone - can't disable speaker

    Thank you, Pyromanic123boom. This did the trick. The answer was to turn PCM down all the way, and Front up all the way.

  4. #4
    Join Date
    Mar 2007
    Location
    Gatineau QC, Canada
    Beans
    28

    Re: Sound from speaker and headphone - can't disable speaker

    If you need another alternative, go see my post here.

  5. #5
    Join Date
    Nov 2009
    Beans
    1

    Re: Sound from speaker and headphone - can't disable speaker

    Thank you pyromanic123boom, it worked well for me too! I'm using an HP laptop, with:
    Card: ATI IXP
    Chip: Analog Devices AD1981B
    Ubuntu FTW!
    Peace out

  6. #6
    Join Date
    Mar 2010
    Beans
    4

    Angry Re: Sound from speaker and headphone - can't disable speaker

    Hi
    I am using Dell Vostro 1014.
    Ubunto 10.04
    This problem persisted with all the various version of Ubuntu through 8.04 to present 10.04, and the solution provided doesn't work for me (unfortunately so) because the 'preferences' in my volume control have only the options Master and PCM, it doesn't have any control for Headphone jack or any such thing. I've tried Kmix but still the situation is the same. I've tried Alsamix and that has absolutely no effect on the sound system for my notebook.

    Please help.

  7. #7
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Sound from speaker and headphone - can't disable speaker

    Quote Originally Posted by manojendu View Post
    Hi
    I am using Dell Vostro 1014.
    Ubunto 10.04
    This problem persisted with all the various version of Ubuntu through 8.04 to present 10.04, and the solution provided doesn't work for me (unfortunately so) because the 'preferences' in my volume control have only the options Master and PCM, it doesn't have any control for Headphone jack or any such thing. I've tried Kmix but still the situation is the same. I've tried Alsamix and that has absolutely no effect on the sound system for my notebook.

    Please help.
    Need some info. Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    cat /proc/asound/version
    head -n 1 /proc/asound/card*/codec#*
    Terminal="Applications->Accessories->Terminal"
    Please post text output using code tags. Also helpful is the make/model of your PC/Laptop.

  8. #8
    Join Date
    Dec 2007
    Beans
    12

    Re: Sound from speaker and headphone - can't disable speaker

    I have a similar problem. I have given the outputs of the commands suggested. Could anyone help me? Also I do not see the volume control applet on the panel.

    I am using HP Pavillion DV6 and Ubuntu 10.04.

    Code:
    uname -a
    Linux
    
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
    cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.21.
    
    head -n 1 /proc/asound/card*/codec#*
    ==> /proc/asound/card0/codec#0 <==
    Codec: IDT 92HD75B3X5
    
    ==> /proc/asound/card0/codec#3 <==
    Codec: Intel G45 DEVIBX
    Last edited by princess9987; May 29th, 2010 at 10:37 PM. Reason: More information

  9. #9
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Sound from speaker and headphone - can't disable speaker

    princess9987 for HP DV6
    OK then. Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert these lines at the bottom:
    Code:
    options snd-hda-intel model=hp-dv5
    options snd slots=snd-hda-intel, snd-hda-intel
    alias snd-card-0 snd-hda-intel
    alias snd-card-1 snd-hda-intel
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default.
    Last edited by lidex; May 30th, 2010 at 02:49 AM.

  10. #10
    Join Date
    May 2007
    Beans
    2

    Angry Re: Sound from speaker and headphone - can't disable speaker

    Hi, I have the same problem, sound came from speakers and headphone, I'm using an ASUA X52Jr

    #uname -a

    Linux elena-laptop 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

    #aplay -l

    **** Lista di PLAYBACK dispositivi hardware ****
    scheda 0: Intel [HDA Intel], dispositivo 0: HDA Generic [HDA Generic]
    Sottoperiferiche: 1/1
    Sottoperiferica #0: subdevice #0
    scheda 1: Generic [HD-Audio Generic], dispositivo 3: ATI HDMI [ATI HDMI]
    Sottoperiferiche: 1/1
    Sottoperiferica #0: subdevice #0

    #cat /proc/asound/version

    Advanced Linux Sound Architecture Driver Version 1.0.22.1.
    Compiled on Feb 8 2010 for kernel 2.6.31-20-generic (SMP).

    #head -n 1 /proc/asound/card*/codec#*


    ==> /proc/asound/card0/codec#0 <==
    Codec: Conexant ID 5069

    ==> /proc/asound/card1/codec#0 <==
    Codec: ATI R6xx HDMI


    can you help me???!!!

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •