Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Problem about Intel 3945 wireless card

  1. #21
    Join Date
    Apr 2008
    Beans
    7

    Re: Problem about Intel 3945 wireless card

    Quote Originally Posted by jasonkirk2006 View Post
    Hey, are you sure it works after several reboots? What is your brand and model? Do you think there are any side effects? (like i mentioned in my old posts - temporary freezes and high CPU utilizations)
    it worked from first reboot, and it connected to my WPA encrypted network. i'm running on a Lenovo 3000 N100 with a centrino duo CPU, and 1 gig RAM, not sure if u need any more into. no side effects experienced so far CPU utilization seems fine on both cores and i dont have any wireless related freezes or anything.

  2. #22
    Join Date
    May 2008
    Beans
    58

    Re: Problem about Intel 3945 wireless card

    I want to ask (i hope) a last thing to those of you which have problems with this funny 3945abg card. May you be using your laptop on AC power and without batteries? I'll be glad if you reply here.

  3. #23
    Join Date
    Nov 2006
    Location
    UK
    Beans
    661
    Distro
    Ubuntu Development Release

    Question Re: Problem about Intel 3945 wireless card

    Quote Originally Posted by jasonkirk2006 View Post
    ...now it says "MAC is in deep sleep" and after updates it may say microcode error or insufficient power etc.)
    If you can manage, don't install any kernel updates for now - keep it with this error so I can track the changes as we go.

    I've been examining the log-files. We're helped by the fact the same card is in this Sony Vaio I'm using so we can compare results between them.

    First thing I want to double-check is the actual PCI device ID since the lspci reports you provided didn't use the -nn option they aren't shown. I want to be absolutely sure we're dealing with the device we think we are! Here's the beginning of the output for this one:
    Code:
    sudo lspci -s 06:00.0 -vvvnn
    
    06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
    	Subsystem: Intel Corporation Unknown device [8086:1051]
    It's the 8086:4222 I'm interested in for now.

    Also, there is a bug report for what seems to be the same issue so please add a comment to it so we can track the issue more easily: "iwl3945 can't wake up Intel(R) PRO/Wireless 3945 mini card"
    Last edited by IntuitiveNipple; September 3rd, 2008 at 04:35 PM.

  4. #24
    Join Date
    Nov 2006
    Location
    UK
    Beans
    661
    Distro
    Ubuntu Development Release

    Question Re: Problem about Intel 3945 wireless card

    Jason, can you capture a boot log without the kernel command-line option "quiet" so we can get more detailed reports in /var/log/dmesg ?

    You should be able to do that manually by interrupting GrUB as it starts, and then editing the menu option's entry by deleting "quiet splash" from the line that starts "kernel" and then, after pressing Enter, pressing B to boot with that entry.

    Also, what make and model is the PC? This error seems to be more frequent with Dell models in the reports I've seen.

  5. #25
    Join Date
    Nov 2006
    Location
    UK
    Beans
    661
    Distro
    Ubuntu Development Release

    Lightbulb Re: Problem about Intel 3945 wireless card

    I'm getting a feeling this is caused by a problem with the Kill Switch as I first thought.

    In the log-file you provided I noticed:
    Code:
    ubu32 kernel: [   36.576191] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    ubu32 kernel: [   36.772058] atkbd.c: Unknown key pressed (translated set 2, code 0x0 on isa0060/serio0).
    ubu32 kernel: [   36.772061] atkbd.c: Use 'setkeycodes 00 <keycode>' to make it known.
    ubu32 kernel: [   36.775036] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    ubu32 kernel: [   36.975457] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    And I found some bug reports for other distributions that link this to the failure of the 3945.

    So, let's try to discover if the failure to read the Kill Switch correctly could be causing this. Do this after you've removed the "quiet splash" options from the kernel command-line so we see more details.

    With the PC switched off ensure the radio kill-switch is in the on position. Start the PC and let it boot. Log-in. From a command prompt start a log-monitor and then move the radio kill-switch to off.

    You should see a few messages reported. When they stop give it a second or two then move the switch back to on. There should be a few more messages. When they've stopped copy the messages to a reply here:
    [code]
    tail -f /var/log/kern.log

  6. #26
    Join Date
    Nov 2006
    Location
    UK
    Beans
    661
    Distro
    Ubuntu Development Release

    Lightbulb Re: Problem about Intel 3945 wireless card

    If you're using a Dell this might be a solution:

    Go to bios (F2 at Dell splash screen) on 'Wireless' go to 'Wi-Fi Catcher' and switch it to 'OFF'.
    (From the thread "Dell XPS M1530 wireless problems")

    If you find this helps add a comment to this bug report "[XPS M1530] Wireless don't work (need to use 'noapic' kernel boot param)"
    Last edited by IntuitiveNipple; September 3rd, 2008 at 05:06 PM.

  7. #27
    Join Date
    May 2008
    Beans
    58

    Re: Problem about Intel 3945 wireless card

    Quote Originally Posted by IntuitiveNipple View Post
    If you can manage, don't install any kernel updates for now - keep it with this error so I can track the changes as we go.

    I've been examining the log-files. We're helped by the fact the same card is in this Sony Vaio I'm using so we can compare results between them.

    First thing I want to double-check is the actual PCI device ID since the lspci reports you provided didn't use the -nn option they aren't shown. I want to be absolutely sure we're dealing with the device we think we are! Here's the beginning of the output for this one:
    Code:
    sudo lspci -s 06:00.0 -vvvnn
    
    06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
    	Subsystem: Intel Corporation Unknown device [8086:1051]
    It's the 8086:4222 I'm interested in for now.

    Also, there is a bug report for what seems to be the same issue so please add a comment to it so we can track the issue more easily: "iwl3945 can't wake up Intel(R) PRO/Wireless 3945 mini card"
    Sorry, before i read your reply, i installed backports module. Now i'm running kernel 2.6.24-19-generic (Hardy 32-bit).

    I'm using the same card with yours. Yes, it's a Dell XPS M1530 and here is what you want:

    Code:
    $ sudo lspci -vv -nn -s 0b:00.0
    0b:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
    	Subsystem: Intel Corporation Unknown device [8086:1021]
    	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    	Latency: 0
    	Interrupt: pin A routed to IRQ 17
    	Region 0: [virtual] Memory at f9eff000 (32-bit, non-prefetchable) [size=4K]
    	Capabilities: [c8] Power Management version 2
    		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
    		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
    	Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    		Address: 0000000000000000  Data: 0000
    	Capabilities: [e0] Express Legacy Endpoint IRQ 0
    		Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
    		Device: Latency L0s <512ns, L1 unlimited
    		Device: AtnBtn- AtnInd- PwrInd-
    		Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
    		Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    		Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
    		Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 0
    		Link: Latency L0s <128ns, L1 <64us
    		Link: ASPM Disabled RCB 64 bytes CommClk- ExtSynch-
    		Link: Speed 2.5Gb/s, Width x1
    Now, as a result of upgraded kernel, "MAC is in deep sleep!" error disappeared. Now dmesg shows no clue. iwconfig lists wlan0 as an interface with wireless extension. But one can identify problem by issuing ifconfig, which does not list wlan0. Further with -a switch it lists:

    Code:
    $ ifconfig -a wlan0
    wlan0     Link encap:Ethernet  HWaddr ff:ff:ff:ff:ff:ff  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    Note that the MAC address is not recognized - so an unfunctional interface.

    Just for reference, here is the filtered dmesg output after removing iwl module, and modprobing it again with disable_hw_scan option.

    Code:
    $ dmesg | grep 3945
    [   24.465371] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.25
    [   24.465373] iwl3945: Copyright(c) 2003-2007 Intel Corporation
    [   24.465502] iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
    [   24.481995] wmaster0: Selected rate control algorithm 'iwl-3945-rs'
    [  163.616883] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.25
    [  163.616891] iwl3945: Copyright(c) 2003-2007 Intel Corporation
    [  163.617084] iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
    [  163.625268] wmaster0: Selected rate control algorithm 'iwl-3945-rs'

  8. #28
    Join Date
    May 2008
    Beans
    58

    Re: Problem about Intel 3945 wireless card

    Quote Originally Posted by IntuitiveNipple View Post
    I'm getting a feeling this is caused by a problem with the Kill Switch as I first thought.

    In the log-file you provided I noticed:
    Code:
    ubu32 kernel: [   36.576191] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    ubu32 kernel: [   36.772058] atkbd.c: Unknown key pressed (translated set 2, code 0x0 on isa0060/serio0).
    ubu32 kernel: [   36.772061] atkbd.c: Use 'setkeycodes 00 <keycode>' to make it known.
    ubu32 kernel: [   36.775036] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    ubu32 kernel: [   36.975457] atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
    And I found some bug reports for other distributions that link this to the failure of the 3945.

    So, let's try to discover if the failure to read the Kill Switch correctly could be causing this. Do this after you've removed the "quiet splash" options from the kernel command-line so we see more details.

    With the PC switched off ensure the radio kill-switch is in the on position. Start the PC and let it boot. Log-in. From a command prompt start a log-monitor and then move the radio kill-switch to off.

    You should see a few messages reported. When they stop give it a second or two then move the switch back to on. There should be a few more messages. When they've stopped copy the messages to a reply here:
    [code]
    tail -f /var/log/kern.log
    Just for quick reply, i must denote that, these lines are the result of misbehaving touchpad. I intentionally skipped this story for the sake of clarity. when i bought my device, it came with BIOS version A07. Having difficulties with the wireless card, i decided to make a BIOS upgrade to A09. But this time touchpad started to act like crazy. Now i'm using i8042.nomux=1 kernel option to aviod this situation. But since i was test driving a clean install then, it was the time before adding this i8042.nomux option to kernel.

  9. #29
    Join Date
    May 2008
    Beans
    58

    Re: Problem about Intel 3945 wireless card

    Quote Originally Posted by IntuitiveNipple View Post
    If you're using a Dell this might be a solution:

    Code:
    Go to bios (F2 at Dell splash screen) on 'Wireless' go to 'Wi-Fi Catcher' and switch it to 'OFF'.

    (From the thread "Dell XPS M1530 wireless problems")

    If you find this helps add a comment to this bug report "[XPS M1530] Wireless don't work (need to use 'noapic' kernel boot param)"
    Sorry, i did applied this in the beginning. Unfortunately, not a fix! Neither wireless catcher, nor the noapic kernel option healed my wound. noapic seemed to do the job at first, bu then i saw problems here and there.

    I will send detailed logs ASAP, but with modified kernel versions.

    Thank you very much for your efforts.

  10. #30
    Join Date
    Nov 2006
    Location
    UK
    Beans
    661
    Distro
    Ubuntu Development Release

    Lightbulb Re: Problem about Intel 3945 wireless card

    I'm going to go out on a limb here, even if I end up wrong. My gut instinct tells me this is a radio kill-switch issue.

    Now you explain the touchpad/BIOS issues, and your usual work-around, that could actually be masking clues for the iwl3945.

    What we need is to see precisely what that driver is getting up to. I'm going to create a special iwl3945 debug module for you to install. It'll use DKMS (Dynamic Kernel Module Support) so you can easily add/remove it and move across different kernel versions. I might be a day or two getting it ready.

    The first run will just through out a lot of debug messages as it initialises so we know everything it encounters. From that we might be in a a better position to point to the cause of this issue. It seems you aren't alone with this (on Dell machines) so we might be helping quite a few others too.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •