Results 1 to 8 of 8

Thread: Wireless keeps asking passphrase

  1. #1
    Join Date
    Aug 2008
    Beans
    30

    Wireless keeps asking passphrase

    Hi, i just installed ubuntu in my lap and i cant get internet connection. When i click the network icon it shows all the detected wireless networks so i chose mine and it asks for the passphrase, i type it and click 'connect'

    Then the icon looks like it's attempting to connect and if i put my mouse over it a dialog says "waiting for network key for the wireless network" and after a while it pops up again asking for me to type the passphrase again. And no, im not writing the pass wrong.

    any idea why?

  2. #2
    Join Date
    Nov 2006
    Location
    OE
    Beans
    2,831
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless keeps asking passphrase

    What type of security do you have? There are many guides here on setting up networks.
    But this guide may be more what you're looking for.
    Since you're having a pass phrase issue take a look at the sections on WEP or WPA whichever is your security type.
    Good site to search for guides & how-tos.

  3. #3
    Join Date
    Aug 2008
    Beans
    30

    Re: Wireless keeps asking passphrase

    it's a wep security

  4. #4
    Join Date
    Nov 2006
    Location
    OE
    Beans
    2,831
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless keeps asking passphrase

    From the link I inserted previously:

    WEP Connection

    You must have either your 64bit or 128 bit HEX Key or the ASCII Equivalent of your HEX Key.

    Code:

    sudo ifconfig <interface> down
    sudo dhclient -r <interface>
    sudo ifconfig <interface> up
    sudo iwconfig <interface> essid "ESSID_IN_QUOTES"
    sudo iwconfig <interface> key HEX_KEY <<<-------- If using ASCII Equivalent, this is s:ASCII_KEY (please make note of the prefix "s:"
    ****Additional Comand that may be needed -- sudo iwconfig <interface> key open <<<----See note below
    sudo iwconfig <interface> mode Managed
    sudo dhclient <interface>

    ***The security mode may be open or restricted, and its meaning depends on the card used. With most cards, in open mode no authentication is used and the card may also accept non-encrypted sessions, whereas in restricted mode only encrypted sessions are accepted and the card will use authentication if available.
    __________________________________________________ __________________________
    Note the prefix mentioned there!
    Last edited by phidia; August 25th, 2008 at 04:09 PM.
    Good site to search for guides & how-tos.

  5. #5
    Join Date
    Jun 2007
    Location
    China
    Beans
    995
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless keeps asking passphrase

    I would try turning roaming off and using the Network manager (System>Administration>network) and setting up your wireless there.

    The config file is /etc/network/interfaces you can check every thing is as it should be.

    mine looks like I'm using WEP encryption and a static IP:

    to lo
    iface lo inet loopback


    iface wlan0 inet static
    address 192.168.1.224
    netmask 255.255.255.0
    gateway 192.168.1.1
    wireless-key s:qxxxxxxxxxxxx
    wireless-essid fish

    auto wlan0

    the s: before the password shows that the password is an ascii phrase.
    Last edited by Gone fishing; August 25th, 2008 at 04:17 PM. Reason: to remove :x

  6. #6
    Join Date
    Aug 2008
    Beans
    30

    Re: Wireless keeps asking passphrase

    Thanks i was looking at that in the link, im looking at my connection properties in my pc and it says web encryption but it doesn't say if it's 128 bit passphrase or 64/128 bit hex or 64/128 bit ASCII...how can i know?

    Cause in the guide it says "You must have either your 64bit or 128 bit HEX Key or the ASCII Equivalent of your HEX Key" by this they mean my pass?

  7. #7
    Join Date
    Aug 2008
    Beans
    30

    Re: Wireless keeps asking passphrase

    [QUOTE=Gone fishing;5661319]I would try turning roaming off and using the Network manager (System>Administration>network) and setting up your wireless there. QUOTE]


    oh that worked fine, thanks

  8. #8
    Join Date
    Oct 2008
    Beans
    3

    Re: Wireless keeps asking passphrase

    [QUOTE=sheroxe;5661394]
    Quote Originally Posted by Gone fishing View Post
    I would try turning roaming off and using the Network manager (System>Administration>network) and setting up your wireless there. QUOTE]


    oh that worked fine, thanks
    im having the same problem, how do you turn roaming off??

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •