Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: New window not on top

  1. #1
    Join Date
    Jul 2008
    Beans
    68

    New window not on top

    Hi,

    I'm using ubuntu 8.04, sometime, when a new window is created, it does not appears on top but behind the current window.
    Is this a known bug ?

    Does the updates of hardy will include gnome updates (new gnome releases) ?

    Thanks for any information
    Last edited by mod-jkl; August 25th, 2008 at 02:34 PM.

  2. #2
    Join Date
    Jul 2008
    Beans
    68

    Re: New window not on top

    Any ideas ?

  3. #3
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: New window not on top

    Are you using the desktop effects? If yes, install the compizconfig settings manager (if you haven't already done that), open it and loook under "general" settings. There's an option for "focus stealing prevention level". Change that to "low" or "none".

  4. #4
    Join Date
    Jul 2008
    Beans
    68

    Re: New window not on top

    No, I don't use any effects ..

    In that case, do I use metacity or compiz ? (having no effects)

  5. #5
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: New window not on top

    Quote Originally Posted by mod-jkl View Post
    No, I don't use any effects ..

    In that case, do I use metacity or compiz ? (having no effects)
    If the desktop effects are disabled you are using Metacity as your window manager.

  6. #6
    Join Date
    Feb 2006
    Beans
    29

    Re: New window not on top

    mod-jkl, I'm having the same issue you are. I've linked to a video of the bug below.

    Like you, after a fresh install of 8.04, some windows do not appear on top and take focus after you open them. In my case, some don't and some do. I don't know which will or will not.

    Here is my setup:
    Fresh install of Ubuntu 8.04 Hardy Heron i386
    Pentium 4 2.4Ghz
    512MB RDRAM
    Changed Visual Effects to "None"

    Thanks in advance for any help! Here's the link to watch the bug in action:

    http://www.vimeo.com/1815384

  7. #7
    Join Date
    Jul 2008
    Beans
    68

    Re: New window not on top

    I have this problem only with firefox and think it is more a firefox bug as the same thing happens on my xp laptop..

    For firefox, I used before a menu item that I created (not to have to go in the internet submenu), now I use the already created firefox item (the one in the internet submenu), and it solved part the problem: at least, when a new firefox window is created by this menu item, it is always on top which was not the case before. Strange as I don't see differences between the 2 menu items, except that one was created during firefox installation and the other was by hand...

    But it doesn't solve your problem..

    Please let me know if you find something.

    ps: if you didn't, you should try to install the updates..

  8. #8
    Join Date
    Sep 2008
    Beans
    1

    Re: New window not on top

    Are you using the desktop effects? If yes, install the compizconfig settings manager (if you haven't already done that), open it and loook under "general" settings. There's an option for "focus stealing prevention level". Change that to "low" or "none

    __________________

    ADOLFO

    internet marketing

  9. #9
    Join Date
    Feb 2006
    Beans
    29

    Re: New window not on top

    I put it in my post that I'm not using desktop effects. I set Visual Effects to "None". And I have read that remedy posted in about 5 other threads that seems to help, but only those people using Compiz Fusion.

    After I read it those 5 other times, I actually thought I'd give it a try (even though I wasn't using any sort of desktop compositing), so I installed compizconfig-settings-manager and followed the same steps in the 5 other threads. No change.

    I have even gone into the gconf-editor under /apps/metacity/general and changed focus_new_windows from "smart" to "strict". Nothing.

    I'm actually pretty frustrated with two bugs that I seem to be the only one experiencing them. I'll see if anyone on IRC can point me in the right direction. If I find something out, I'll let you know.

  10. #10
    Join Date
    Feb 2006
    Beans
    29

    Re: New window not on top

    Okay, I feel a little better knowing what is causing this problem on my end, but not so good knowing that I have to make a change to my desktop to stop something that happens some times, but not others.

    If you noticed in my bug video, I have the Audacious Media Player running. I have "Always On Top" turned on so that I can always see the playlist and always have access to the playback controls. It turns out that is what was causing the erratic behavior. Now, instead of some windows coming to the foreground and taking focus and others not, now, they all come to the foreground and take focus.

    So, yay! I found out what causes the problem. But now that I've disabled "Always On Top", it makes it more inconvenient to listen to music.

    So, why do some of the windows, like the "Main Menu" window come to the front and take focus and others not? Is this a bug in Gnome, Metacity, Audacious, each other program that doesn't come to the foreground and take focus? Oh, bother. Hope this helps you!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •