Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: configuring 5.1 speakers

  1. #1
    Join Date
    Aug 2008
    Beans
    7

    Question configuring 5.1 speakers

    Hi guys, I am absolutely new to ubuntu and i cannot configure my 5.1 speakers (i have onboard 5.1 sound controller). I came across a post where a guy was talking about some code but i couldnt make out properly what to do. Can someone plz tell me the step by step procedure? Again, i am absolutely new to linux and ubuntu.

  2. #2
    Join Date
    Feb 2007
    Beans
    23,875
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: configuring 5.1 speakers

    Hi and welcome, please do not create multiple threads on the same issue.

  3. #3
    Join Date
    Aug 2008
    Beans
    7

    Re: configuring 5.1 speakers

    Quote Originally Posted by overdrank View Post
    Hi and welcome, please do not create multiple threads on the same issue.
    Im sorry but the previous thread i created got no replies to it and i couldnt find it to continue it

  4. #4
    Join Date
    Feb 2007
    Beans
    23,875
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: configuring 5.1 speakers

    Quote Originally Posted by theguitarfreak View Post
    Im sorry but the previous thread i created got no replies to it and i couldnt find it to continue it
    Hi and you can find you thread by using the search, find all your post. If not answered you can bump it after 24 hrs.

  5. #5
    Join Date
    Mar 2008
    Location
    UK
    Beans
    232
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: configuring 5.1 speakers

    I had the same problem, now solved:
    http://ubuntuforums.org/showthread.php?t=886807

  6. #6
    Join Date
    Aug 2008
    Beans
    7

    Re: configuring 5.1 speakers

    pcm.!default {
    type plug
    slave.pcm "softvol"
    }

    pcm.softvol {
    type softvol
    slave {
    pcm "ch51dup"
    }
    control {
    name "All"
    card 0
    }
    }

    pcm.ch51dup {
    type route
    slave.pcm surround51
    slave.channels 6
    ttable.0.0 1
    ttable.1.1 1
    ttable.0.2 1
    ttable.1.3 1
    ttable.0.5 0.5
    ttable.1.5 0.5
    }

    I used the above code in a text file and saved it as .asoundrc in my home folder. But still i dont get sound from my rear speakers. I am using amarok player.

  7. #7
    Join Date
    Mar 2008
    Location
    UK
    Beans
    232
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: configuring 5.1 speakers

    Check all sliders are up in your mixer (you should also have a new slider named "All").
    Check that 'surround jack mode' is set to 'shared'
    Check that amarok is using 'default' for its stereo device.

  8. #8
    Join Date
    Aug 2008
    Beans
    7

    Re: configuring 5.1 speakers

    Quote Originally Posted by Chris Musampa View Post
    Check all sliders are up in your mixer (you should also have a new slider named "All").
    Check that 'surround jack mode' is set to 'shared'
    Check that amarok is using 'default' for its stereo device.
    Im using GNOME ALSA Mixer. There isnt any new slider named "All" as you are saying and i have put a tick on "Sorround Jack Moder" in the mixer.

  9. #9
    Join Date
    Mar 2008
    Location
    UK
    Beans
    232
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: configuring 5.1 speakers

    The above worked for me (I use kde rather than gnome, not sure why that should make any difference), the new slider appeared in kmix after a reboot. Sorry I can't offer you anymore advice guitarfreak as I'm also fairly noob.

  10. #10
    Join Date
    Aug 2008
    Beans
    7

    Re: configuring 5.1 speakers

    Getiing sounds from all the speakers finally but aint getting proper channel controls in the mixer. And when i am interchaning the rear and center/subwoofer jack, i am getting better bass frequencies.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •