Results 1 to 6 of 6

Thread: Mythtv kicks me out to desktop

  1. #1
    Join Date
    Jun 2008
    Beans
    46

    Mythtv kicks me out to desktop

    Hey guys,

    Ive got an old dell latitude c610 laptop i've installed the mythtv frontend on. It can talk to the database just fine, but when i try to watch tv, the screen goes blank and kicks me out to the desktop. There are no errors in the frontend logfile.

    The frontend works fine when i boot from the mythbuntu live cd. Obviously, this isn't something that is possible to do all the time.

    Any ideas?

    Thanks.

  2. #2
    Join Date
    May 2006
    Location
    Southern California
    Beans
    867
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mythtv kicks me out to desktop

    Run mythfrontend from a terminal:
    Code:
    mythfrontend -v all
    and look at the errors.
    Usually, it's either the directory to hold recordings doesn't exist or, if it does, myth doesn't have permissions to write to it.
    Live TV writes to the recording directory... so it's not really 'live' but cached so you can pause, ffw, & rewind.
    (Master be/fe) ASUS P5KPL IPC, E5400, KVR800D2N6K2/2G, 8500GT, (2)PVR-150, A180, ATSC-115, U10.04, MythTV 0.23-fixes.

  3. #3
    Join Date
    Jun 2008
    Beans
    46

    Re: Mythtv kicks me out to desktop

    Thanks for the tip. Don't know why i didn't think of that. I'll give that a shot and let you know how it goes.

  4. #4
    Join Date
    Jun 2008
    Beans
    46

    Re: Mythtv kicks me out to desktop

    Looks like its seg faulting:

    2008-08-21 22:42:41.787 write -> 22 49 QUERY_FILETRANSFER 24[]:[]REQUEST_BLOCK[]:[]65536
    2008-08-21 22:42:41.786 AO: no change exiting
    2008-08-21 22:42:41.787 AO: Pause 1
    2008-08-21 22:42:41.787 AO: OutputAudioLoop: audio paused
    2008-08-21 22:42:41.788 AO: 65536 bytes free on soundcard
    2008-08-21 22:42:41.790 AO: 61824 bytes free on soundcard
    2008-08-21 22:42:41.792 AO: 58144 bytes free on soundcard
    2008-08-21 22:42:41.795 AO: 58544 bytes free on soundcard
    2008-08-21 22:42:41.797 AO: 58944 bytes free on soundcard
    Segmentation fault

    Also, sometimes i get Unable to open mixer ALSA:default followed by a seg fault.

    Im a noob when it comes to linux sound drivers...but maybe using alsa is the issue...any clues?

    I've also tried setting sound device to NULL with no luck. same seg fault.
    Last edited by kristersaurus; August 22nd, 2008 at 04:53 AM.

  5. #5
    Join Date
    Dec 2006
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mythtv kicks me out to desktop

    It's a known bug if you have xserver-xgl installed.

    Came back to edit and now not sure .. ..

  6. #6
    Join Date
    Jun 2008
    Beans
    46

    Re: Mythtv kicks me out to desktop

    good thinking, but I do not have xserver-xgl installed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •