Page 15 of 16 FirstFirst ... 513141516 LastLast
Results 141 to 150 of 153

Thread: Atheros ar928x working...

  1. #141
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    Am I correct in thinking that Ndiswrapper does NOT work for this chipset?

    I've just installed Ndiswrapper, downloaded the M$ driver but can't get it to work - although it installs ok, rebooting or modprobing ndiswrapper doesn't even find the wireless hardware. I've had some success with Ndiswrapper with another Atheros card sos I'm pretty sure I'm doing things right...

  2. #142
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    A little progress. Most people seem to be sourcing their M$ driver from this site - http://www.atheros.cz/. The thing is that although you are presented with an extensive selection (multiple OS's etc) in reality there is just one download for this driver - and it's a Vista/System7 driver, which is not NDiswrapper-compatible, it will only work with XP-drivers!

    Luckily I had a system disk from a mini-pc which contained the driver and I've uploaded it in case someone wants to try it;

    http://ubuntuone.com/2drDSaucgcVc78ZYfAITTH

    Now the Ndiswrapper-installed driver is instantly picked up by the kernel. But that's as good as it gets. Trying to set up a ad-hoc network, it resolutely refuses to create any sort of network connection, just scanning & scanning - it even does the same when set to "share to other computers" which requires no connection to be completed, which is maddening. Trying to assign it a client-role & connect to another pc also fails. Also, disabling encryption has no effect...

    I'm sure if there is a hell, it's networked by Linux/ad-hoc wireless boxes! Linux's wireless sucks generally, but the ad-hoc support is really shambolic and doesn't even appear to be tested in many cases. For instance, running the latest Hiren 14.1 rescue-cd and in Linux-LiveCD-mode, the latest & greatest WiCD cannot be used to join a ad-hoc network, complaining about a bad-password. And the reason seems clear - it flashes up text saying "WPA" when it tries to connect! Something that the developers would have immediately caught had they ever tried it! What sucks is that ad-hoc networking works perfectly if you choose to boot in XP_LiveCD-mode... Also, on Mageia, the latest KDE's Network-Manager is practically useless with ad-hoc, being relegated to no more than a glorified applet as you can only connect to 'system-created' networks & which it cannot edit in any way. Create a connection through it and it refuses to connect with it...

  3. #143
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Atheros ar928x working...

    omelette: ndiswrapper can be fickle. You might have better luck if you use a different version of the Windows driver--e.g., try the Windows 2000 driver, or version 1.0 of the driver instead of 2.0.

    By the way, I don't know what your situation is, but perhaps you could avoid ad-hoc networking altogether by setting up another Linux computer as an AP station. One of the nice things about Linux wireless is that most of the native drivers now support AP mode, allowing you essentially to use your computer as a real router, without doing ad-hoc. Ad-hoc support may not be as solid as you would like (although it sounds like the issues you're having have more to do with the particular clients you're using than the wireless drivers), but Linux does make a quite impressive showing when it comes to advanced wireless features. I've only very rarely heard of any Windows wireless drivers supporting AP mode, for instance.

  4. #144
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    @pythes22 - Thanks, your info about AP's had me scurrying off looking it up - I thought there was only 2 options available! Unfortunately the current Ubuntu 10.04LTS wireless driver does not appear to support 'Master' mode which from my reading of the Ubuntu WIFI docs seems to be a prerequisite.

    I'm doubtful that a Win2k ar928x driver exists, at least it's not listed as being available at the above Atheros-drivers site, and even finding 'newer' XP Atheros-drivers is a chore (above site excepted) which surprised me.

    What sticks in my craw regarding Linux & ad-hoc is that it is obvious (to me anyway!) that developers no longer even support this mode now, never mind fix the multiple bugs that exist! The one recent exception to this rule seems to have been a kernel-bug (2.6.38-8 if memory serves) that effects the client-side of an ad-hoc connection - at least with Fedora, this bug had been identified & removed with 2.6.40. Incidentally the then brand-new Ubuntu 11.04 also suffered from this, and probably still does given Ubuntu's lethargic kernel updates! This and a buggy Gnome3 was the reason I switched back to my reliable old Ubuntu 10.04LTS.

    I've been threatening to get a router for ages, maybe the time has arrived...

  5. #145
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Atheros ar928x working...

    omelette: I've never done master mode on Ubuntu myself, but I think it should work as long as your driver supports it. But that depends on which particular driver you're using, which in turn depends on your wireless chipset. With some drivers the support is not yet there.

    By the way, have you tried using the ath9k driver (which does support master mode, by the way) to drive your device? If it's an ar928x chip it should work--although if it's really new perhaps you'll have to compile the driver from source using the latest code rather than Ubuntu's version.

    Or, yes, just buy a router--they're quite cheap these days

  6. #146
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    @Pytheas22 - Some more searching revealed that Master-mode is indeed possible with my chipset, it just that my simplistic 'iwconfig' check wasn't enough - iwconfig can't initialise Master-mode. So I've made some more progress, when I finally managed to get the AP up and running, all the problems I was experiencing with over the ad-hoc link - long-winded version available here-> http://ubuntuforums.org/showthread.p...4#post11305314 - seems to have vanished!

    The bad news, getting an AP running proved a bit of a nightmare. In principle it's fairly simple - just install 'hostapd', configure hostapd.conf, allow it to auto-start at boot by enabling it in /etc/default/hostapd (the default is 'disabled' which is just plain silly). Once done, iwconfig list wlan0 as being in Master-mode and the client picks it up as such. But that's it, it absolutely refuses to complete the connection! After many hours I finally managed to 'fudge' it by enabling a ad-hoc connection, disabling & re-enabling ath9k then finally restarting hostapd...

    Turns out I'm not to first to come across this either and a solution appears elusive. Someone said the fix was to build the compat-wireless drivers from the latest source, which I did but was no help. Then I found someone else saying that it's hostapd that's the problem, so I tried & failed at re-building that - my 10.04LTS has too many old core-libraries and I kept getting 'too old a version' failures. But for the latest Ubuntu's it should be pretty simple to build.

    So at least I have the satisfaction of having a more secure wpa2 connection at the moment, even if it's not really viable long-term.

  7. #147
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Atheros ar928x working...

    omelette: sorry to hear AP mode didn't turn out to be as effective in practice as in theory, but kudos to you for going to so much work trying to get it up and running. It may be that the driver support just isn't really there yet for your chip, unfortunately. But where would be the fun in Linux if it always worked perfectly?

  8. #148
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    @pytheas22 - if 'fun' is synonymous with Linux not working perfectly then its one hell of a party we've got going here!

    For what it's worth, I had another go at compiling 'hostapd' and succeeded largely as a result of finding a Wiki-entry on hostapd which listed the error I was getting & the solution - I just needed to install 'libssl-dev'. Didn't help though. I built both 0.6.10 and 0.7.3 versions successfully but none of them even run properly, each producing different error(s). In fact the only ones that runs properly (not connecting excepted!) is 0.6.9 - the one in the repository. So I've had enough of it and will leave it at that.

  9. #149
    Join Date
    Dec 2008
    Beans
    142

    Re: Atheros ar928x working...

    Just thought I'd post a little update regarding my experience with AP-networking connections - its been a whole month now! - just in case some long-suffering ad-hoc users happen to google across my problem.

    It turns out that the Linux ad-hoc implementation is even more crappy than I had assumed. Since I've been using AP's, another networking bug that I had thought was unrelated to ad-hoc has completely vanished, namely the ad-hoc network share just disconnecting, mainly when data-throughput was high. To give you an idea of how bad this was, while downloading a 800meg torrent, it disconnected 6 times! Until I figured out how to restart the ad-hoc connection manually, I had actually been reduced to restarting the computer each time this happened, which made the whole thing barely usable. This nightmare has completely vanished with AP-connections!

    It's actually pretty simple to implement too, the only niggle being that the server-side of things needs to be started manually when the computer (re)starts, but once everything is setup, this just involves a single "sudo service hostapd restart" command. Very important though, even though you are now using AP/WPA2 connections, you must setup and run a 'dummy' ad-hoc connection as well - otherwise, the client-side fails to connect! And if you are nervous about the obvious security considerations of an open-but-unused ad-hoc connection, you can safely disable/delete it once the AP connection is running, but as I mentioned, if you reset the computer, it will be needed again. Personally, I just set up a 128bit-key ad-hoc connection and leave it running, as another one of ad-hoc's numerous bugs seems to be that it will only connect with the 40bit key - so even if someone still had the password, they still couldn't connect with it!

    In conclusion, imo AP rocks and anyone still using ad-hoc should switch immediately!

  10. #150
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Atheros ar928x working...

    omelette: so you finally got hostap working? Did you use the version in the repositories?

Page 15 of 16 FirstFirst ... 513141516 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •