Results 1 to 10 of 153

Thread: Atheros ar928x working...

Threaded View

  1. #1
    Join Date
    Aug 2008

    How-To: Atheros ar928x working...


    After 10 days of hard work and headaches, I got my Atheros ar928x wireless card working. I hope this thread can help others:

    - I have an Atheros ar928x wireless card (see below for "lspci" output), and I got it working by doing what Volanin says in post #5 in the thread It worked for me in 32bit and now in amd64.

    Long story:
    (some people may identify with me or have similar problems).

    My new laptop PC is a Sony Vaio SR129E/B, bought 3 weeks ago, in Newegg.
    In the specifications of the seller's webpage, and on Sony's webpage, it didn't specify the exact model of the Atheros wireless card.
    (official Sony page of the laptop ). The only way to find it was by looking in the "device manager" of
    windows vista, right-clicking the card and selecting properties.

    When I typed in the terminal:
    lspci -nn
    the output for my wireless card was:

    05:00.0 Network controller [0280]: Atheros Communications Inc. Unknown device [168c:002a] (rev 01)
    and this command:
    lshw -C Network

    *-network UNCLAIMED
    description: Network controller
    product: Atheros Communications Inc.
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:05:00.0
    version: 01
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list
    configuration: latency=0
    I had installed Ubuntu 8.04, amd64.

    I tried using ndiswrapper many times. I used the Windows drivers installed on the Vista partition of my PC; they didn't work. I then tried downloading Windows drivers from:
    then from:
    and finally from:

    None worked, and ndiswrapper spammed dmesg with errors trying to load the Windows driver, athrx.inf.

    I downgraded my Ubuntu to 32-bit, hoping that ndiswrapper would work better there, but got the same errors as I had on 64-bit. I also compiled ndiswrapper from source, to no avail.

    Finally, with the link that I mentioned in the summary above, I got the card working using the ath9k drivers, which were just released in July 2008 (and should support all Atheros ar9xxx chipests). And as it worked perfectly, I decided to return to my 64-bit version (which I had compromised in the hope of getting the wireless card working), and it also ran smoothly.


    Special thanks to pytheas22 for his patience, generosity, since he led me in this process, and never lost hope!
    Last edited by a3qp; August 19th, 2008 at 06:58 AM. Reason: include How-To in the title...

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts