Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: [SOLVED] Spyware in my Ubuntu Firefox?

  1. #11
    Join Date
    Apr 2008
    Location
    London, UK
    Beans
    590
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    You are probably behind a router. Your IP address is in the private address block (192.168.xx etc)

    You should find your router and do a hard reset to make sure there are no dodgy settings within that. When you have done that, make sure you enable any security settings within the router such as firewalls etc, and disable UPnP if on there.

    As for your PC, remove and reinstall firefox with no extensions and try again. Hopefully this should help

    Edit: To hard reset router, locate the small hole usually on the bottom of it that says reset next to it and use a pin or other thin object to press the button in whilst the router is still switched on. The lights may flash or go out and come back on depending on model etc.

    The router should then reset with good security settings already enabled (unless it is a wireless router also in which case you should enable WPA security) to do this type into your web browser 192.168.2.1 or whatever the ip address of the router is.
    Last edited by scottuss; August 18th, 2008 at 04:02 PM. Reason: Added more detail

  2. #12
    Join Date
    Sep 2007
    Location
    cyberspace
    Beans
    77
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Spyware in my Ubuntu Firefox?

    as it has already been stated using no-script is a good idea. instead of allowing all sites to run javascript you have to add them to a whitelist first (trusted).

    In the days of XSS (cross site scripting) and browser hijacks its best to take a few precautions especially if you frequent dodgy sites?!

  3. #13
    Join Date
    Aug 2008
    Location
    Philippines
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    Quote Originally Posted by linux6994 View Post
    2. Under Ubuntu go to System > Administration > Network and ensure that you have the same dns and gateway a in XP.
    Under the DNS tab:
    DNS Servers
    121.1.3.208
    121.1.3.199
    203.84.191.216

    Search domains
    meridiantelekoms.com
    Under the Hosts tab:
    (Please click here for the screenshot.)

    This is what I got from the netstat -r command:
    rivertam@RiverTam:~$ netstat -r
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.224.0 * 255.255.224.0 U 0 0 0 eth1
    link-local * 255.255.0.0 U 0 0 0 eth1
    default 192.168.224.1 0.0.0.0 UG 0 0 0 eth1

  4. #14
    Join Date
    Aug 2008
    Location
    Philippines
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    Quote Originally Posted by vjkeito View Post
    have you tried another browser usch as epiphany to see if that does the same?
    Yep, I'm using Galeon 2.0.4 right now to post these messages. It's doing well so far, but I'm getting paranoid.

    perhaps purgin firefox and re-installing might help?
    Let me try that again...nope. There it is again.

  5. #15
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,803
    Distro
    Ubuntu Development Release

    Re: Spyware in my Ubuntu Firefox?

    Quote Originally Posted by laurenipsum View Post
    I didn't think it was possible, but I might have spyware on my Firefox -
    First, you need to confirm if it is a firefox issue or something else; download another browser such as Opera, Galeon and/or Epiphany. You can also use lynx in a pinch;
    Code:
    sudo apt-get install lynx
    Then check the affected pages using the new browsers.

    I doubt it's a browser issue; maybe your DNS/Proxy settings are being subverted somehow.

    Post back results on checking with alternate browsers.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  6. #16
    Join Date
    Aug 2008
    Location
    Philippines
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    Quote Originally Posted by ModelM View Post
    You might want to make sure Firefox isn't using a proxy.
    Okay, I just checked, and it was set to "Use System Proxy Settings." I ticked "No proxy," and still the telltale "Connection interrupted" error message. (The message also crops up whenever I force an https: when typing URLs.)

    Quote Originally Posted by Kevbert View Post
    If you think anyone has compromised your system you could try Wireshark which is in the repos. From that you can use the Network Tool Whois? (with Hardy Heron by default) to find out who's IP is guilty of snooping.
    I've noted this suggestion, thanks! Once I've researched a bit more, I'll get back to you. By the way, I'm finding it hard to download NoScript. Using the "Get Add-ons" function from within FF 3.0, I'm getting this message:


    And again, can't access the Add-ons page within the browser itself. FF is having a difficulty with https:, it seems.

    Quote Originally Posted by vjkeito View Post
    simple, do you own a router? what ISP are you with, did they provide you with a router (wifi?!) or have you only got a modem?
    God, sorry, I'm pretty ignorant about these things. But if you meant this kind of router, nope, I don't have it. I'm on broadband; I see this cord connected to a socket in my computer which goes out my window and culminates in an antenna on my roof. Errr, sorry.

  7. #17
    Join Date
    Aug 2008
    Location
    Philippines
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    Quote Originally Posted by scottuss View Post
    You are probably behind a router. Your IP address is in the private address block (192.168.xx etc)

    You should find your router and do a hard reset to make sure there are no dodgy settings within that. When you have done that, make sure you enable any security settings within the router such as firewalls etc, and disable UPnP if on there.
    Thanks so much, I'll do this as soon as I understand where my router is, if I have one. /is stupid with cables and such

  8. #18
    Join Date
    Aug 2008
    Location
    Philippines
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Spyware in my Ubuntu Firefox?

    Dammit. They found me.

    I mean, I've been using Galeon to browse this forum, so I thought it was a FF thing, and I just got redirected to that fake search engine again. I've just installed Epiphany, currently testing it as well. Update: Epiphany has succumbed to the evil, too.

    Oh, and I was finally able to install NoScript via Applications>Add/Remove. It's too late, though, the fake search engine loads nonetheless.

    Hmmm...if it's a router problem, why isn't my Windows Firefox affected?

  9. #19
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,803
    Distro
    Ubuntu Development Release

    Re: Spyware in my Ubuntu Firefox?

    Your DNS server settings seem fine in the Windows output you posted; are you using the same in Ubuntu? Open a terminal (Applications-Accessories-Terminal) and check
    Code:
    cat /etc/resolv.conf
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  10. #20
    Join Date
    Dec 2007
    Location
    Shepperton, UK.
    Beans
    2,489
    Distro
    Ubuntu Development Release

    Re: Spyware in my Ubuntu Firefox?

    You can also get No-script from the website. Another useful Add-on is Adblock Plus which stops you having to load adverts and banners.
    Intel E5700 G41 8Gb Xubuntu 13.10, Ubuntu 13.4, WinXP.
    Revo R3610 Win7 Pro, Ubuntu 13.04

    Absolute Beginners Compiz-fusion wiki Local Weather

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •