Results 1 to 8 of 8

Thread: windows Mount problem

  1. #1
    Join Date
    Dec 2007
    Beans
    56

    windows Mount problem

    Hi.

    I have a double boot ubuntu 8.04/ XP.
    the thing is that the /boot directory was erased from XP and I don't have the CD.
    i have a backup on an external drive.
    so Everything would be ok if ubuntu let me mount my xp drive.

    I've done this several times:
    Code:
    rui@rmx:~$ sudo mount -t ntfs-3g /dev/sda1 /media/windows -o remove_hiberfile
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:
    
    Choice 1: If you have Windows then disconnect the external devices by
              clicking on the 'Safely Remove Hardware' icon in the Windows
              taskbar then shutdown Windows cleanly.
    
    Choice 2: If you don't have Windows then you can use the 'force' option for
              your own responsibility. For example type on the command line:
    
                mount -t ntfs-3g /dev/sda1 /media/windows -o force
    
        Or add the option to the relevant row in the /etc/fstab file:
    
                /dev/sda1 /media/windows ntfs-3g force 0 0
    and

    Code:
    rui@rmx:~$ sudo mount -t ntfs-3g /dev/sda1 /media/windows -o force
    Windows is hibernated, refused to mount.
    Failed to mount '/dev/sda1': Operation not permitted
    The NTFS partition is hibernated. Please resume and shutdown Windows
    properly, or mount the volume read-only with the 'ro' mount option, or
    mount the volume read-write with the 'remove_hiberfile' mount option.
    For example type on the command line:
    
                mount -t ntfs-3g /dev/sda1 /media/windows -o remove_hiberfile
    And I added to fstab the following line
    /dev/sda1 /media/windows ntfs-3g force 0 0


    But last time I shutdown XP (when I erased the /boot), so windows is not hibernated.

    Anyway I can't boot windows, so I guess I must "cheat" ubuntu somehow.

    Any clue?

    Thanks

    Rmx

  2. #2
    Join Date
    Jul 2007
    Beans
    1,062
    Distro
    Ubuntu Development Release

    Re: windows Mount problem

    Add the "ro" command suggested.
    "In a world without walls and fences, who needs windows and gates?" Having trouble compiling drivers in a different kernel?, Dual Boot Tutorial Ubuntu Hardware Support List

  3. #3
    Join Date
    Dec 2007
    Beans
    56

    Re: windows Mount problem

    Yeah
    That way I can mount the drive, but only read only
    And I need to write on it

  4. #4
    Join Date
    Dec 2007
    Beans
    56

    Re: windows Mount problem

    Anyone has a clue?

    Thanks

    Rui

  5. #5
    Join Date
    Nov 2007
    Location
    Kuwait
    Beans
    286

    Re: windows Mount problem

    just curious did you try

    mount -t ntfs-3g /dev/sda1 /media/windows -o remove_hiberfile

  6. #6
    Join Date
    Dec 2007
    Beans
    56

    Re: windows Mount problem

    I've done that as I said before:

    Quote Originally Posted by rmx View Post
    Hi.

    I've done this several times:

    Code:
    rui@rmx:~$ sudo mount -t ntfs-3g /dev/sda1 /media/windows -o remove_hiberfile
    
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda1': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:
    
    Choice 1: If you have Windows then disconnect the external devices by
              clicking on the 'Safely Remove Hardware' icon in the Windows
              taskbar then shutdown Windows cleanly.
    
    Choice 2: If you don't have Windows then you can use the 'force' option for
              your own responsibility. For example type on the command line:
    
                mount -t ntfs-3g /dev/sda1 /media/windows -o force
    
        Or add the option to the relevant row in the /etc/fstab file:
    
                /dev/sda1 /media/windows ntfs-3g force 0 0
    and

    Code:
    rui@rmx:~$ sudo mount -t ntfs-3g /dev/sda1 /media/windows -o force
    
    Windows is hibernated, refused to mount.
    Failed to mount '/dev/sda1': Operation not permitted
    The NTFS partition is hibernated. Please resume and shutdown Windows
    properly, or mount the volume read-only with the 'ro' mount option, or
    mount the volume read-write with the 'remove_hiberfile' mount option.
    For example type on the command line:
    
                mount -t ntfs-3g /dev/sda1 /media/windows -o remove_hiberfile
    And I added to fstab the following line
    /dev/sda1 /media/windows ntfs-3g force 0 0
    Rmx

  7. #7
    Join Date
    Dec 2007
    Beans
    56

    Re: windows Mount problem

    anymore sugestions please?

  8. #8
    Join Date
    Dec 2007
    Beans
    56

    Re: windows Mount problem

    please please please?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •