Results 1 to 5 of 5

Thread: How come pressing Super+D doesn't show my desktop?

  1. #1
    Join Date
    Oct 2007
    Location
    Freeland, MI
    Beans
    73
    Distro
    Ubuntu 8.04 Hardy Heron

    Question How come pressing Super+D doesn't show my desktop?

    How come pressing Super+D doesn't show my desktop? I tried setting the key combination to perform this task, but upon holding Super, about to press D, it immediately sets the key combination to just "Super L". What wouldst thou deau?

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How come pressing Super+D doesn't show my desktop?

    You might check gonf-editor's apps/metacity settings to see if you have the single "Super_L" , "Super_R" or "Super" key assigned to something already.

    I use gconf-editor to assign my shortcuts. For some reason, I cannot get <Super_L>d or <Super_R>d to work individually. However, I can get <Mod4>d or <Super>d to work using either Super key (L or R). If you want either Super key to work, run this command:
    Code:
    gconftool-2 --set --type string /apps/metacity/global_keybindings/show_desktop '<Mod4>d'
    or
    Code:
    gconftool-2 --set --type string /apps/metacity/global_keybindings/show_desktop '<Super>d'
    Last edited by drs305; August 15th, 2008 at 10:27 PM.
    Back to Xorg...

    Retired.

  3. #3
    Join Date
    Nov 2005
    Location
    New York, USA
    Beans
    1,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How come pressing Super+D doesn't show my desktop?

    The standard key combination for this in Ubuntu is ctrl/alt/d. If you want to change that, run the configuration editor.
    Code:
    gconf-editor
    On the left side, you will then navigate to:
    /apps/metacity/global_keybindings

    On the right side of the screen, scroll down to the "show_desktop" entry and double click it. The default entry says:
    Code:
    <Control><Alt>d
    change this to:
    Code:
    <super>d
    When you hit enter, the change take affect immediately.

    Ideally, you should glue an ubuntu logo over the windows logo on the super key when you do this.
    Using Ubuntu since Warty Warthog (4.10)
    32 bit 5.04>5.10>6.06>6.10>7.04>7.10>8.04>8.10>9.04>9.10
    64 bit 9.10 upgraded to 10.04>10.10>11.04>11.10>12.04>14.04

  4. #4
    Join Date
    Apr 2009
    Beans
    55
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: How come pressing Super+D doesn't show my desktop?

    Here's how to do it with the GUI:

    http://warrence.com/tech/?p=22

  5. #5
    Join Date
    Nov 2006
    Location
    Switzerland
    Beans
    183
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: How come pressing Super+D doesn't show my desktop?

    have you tried setting it in compizconfig-settings-manager?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •