Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Numlock Problem with Logitech MX5500

  1. #1
    Join Date
    Sep 2005
    Beans
    45

    Numlock Problem with Logitech MX5500

    Hello you all,

    This post is same time a noob question and warning for all who wants to buy new Logitech MX 5500 Keyboard.

    Problem: There is no Numlock key in MX 5500 keyboard
    Annoyance: When i push any numberkey from numpad (intentionally or unintentionally), Ubuntu logs out current session from X. I haven't yet tested what happens when i'm using console

    So... is there any other way to enable numlock than using a startup script.
    Last edited by terrrorr; August 15th, 2008 at 10:44 AM.

  2. #2
    Join Date
    Sep 2005
    Beans
    45

    Re: Numlock Problem with Logitech MX5500

    Ok...

    Here is more info. If i use console(eg ctrl+alt+f2), everything works fine. But when i'm running X all gets messed up (Even in terminal session).

    I thought that i could solve this out when i change keyboard layout, manufacture or layout options but... no winner...

    is it Linux's, Ubuntu's or MX5500's problem... i do not know.

  3. #3
    Join Date
    Oct 2008
    Beans
    12

    Re: Numlock Problem with Logitech MX5500

    I also have a Logitech MX5500 and am suffering this problem.
    The numlock key does not exist, its been replaced by a "Clear Calculator" key, which makes the pc speaker beep every time its pressed.

    If I open a text editor, the numpad keys 4 and 6 simply move the cursor the way the arrow keys would.

    In SYSTEM > PREFERENCES > KEYBOARD, Allow to control pointer using keyboard is not enabled. If I enable it, it controls the pointer

    The symbol keys on the numpad work (/ * - +) and enter, however the fullstop key does not.

  4. #4
    Join Date
    Oct 2008
    Beans
    12

    Re: Numlock Problem with Logitech MX5500

    Quote Originally Posted by terrrorr View Post
    is it Linux's, Ubuntu's or MX5500's problem... i do not know.
    I believe it could be a problem with ubuntu (or gnome?) as I booted into a live cd of mandriva a few days ago and the keypad worked fine...

  5. #5
    Join Date
    Oct 2008
    Beans
    12

    Re: Numlock Problem with Logitech MX5500

    Well incase anyone reads this months/years into the future and has the same problem, i've found a workaround.

    First, install numlockx
    sudo apt-get install numlockx

    Then create a script to turn it on.
    sudo gedit /etc/init.d/numlockon

    Enter these two lines of code to your blank script. Save and close gedit.
    #!/bin/bash
    numlockx on


    Make your script executable
    sudo chmod +x /etc/init.d/numlockon

    Then type this thing that does something that makes it work..
    sudo update-rc.d /etc/init.d/numlockon defaults



    Reboot and enjoy having a functioning numpad!

  6. #6
    Join Date
    Apr 2008
    Location
    KY - USA
    Beans
    16
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Numlock Problem with Logitech MX5500

    Quote Originally Posted by Chookah View Post

    Then type this thing that does something that makes it work..
    sudo update-rc.d /etc/init.d/numlockon defaults

    When I enter this command, I get an error. Everything else completed normally.

    update-rc.d: /etc/init.d//etc/init.d/numlockon: file does not exist

    Now I know your looking at the "//" between init.d and etc, but I am copying and pasting the line. It's not there when I enter it. I've tried manually as well and still no go.

  7. #7
    Join Date
    Oct 2008
    Beans
    12

    Re: Numlock Problem with Logitech MX5500

    Quote Originally Posted by Alehbye View Post
    When I enter this command, I get an error. Everything else completed normally.

    update-rc.d: /etc/init.d//etc/init.d/numlockon: file does not exist

    Now I know your looking at the "//" between init.d and etc, but I am copying and pasting the line. It's not there when I enter it. I've tried manually as well and still no go.
    What happens if you enter this instead...
    sudo update-rc.d numlockon defaults

  8. #8
    Join Date
    Oct 2007
    Location
    Dorset
    Beans
    8
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Numlock Problem with Logitech MX5500

    Thanks for that Chookah, it worked.

  9. #9
    Join Date
    Jun 2006
    Location
    Roanoke, VA
    Beans
    152
    Distro
    Ubuntu Development Release

    Arrow Re: Numlock Problem with Logitech MX5500

    There's a much simpler solution to this.

    1. Go into System -> Preferences -> Keyboard.
    2. In the Layouts tab, click Options on the bottom left.
    3. In the tree, find the section called Miscellaneous Compatibility Options.
    4. Under this section, check the option titled Numeric keypad keys work as with Mac.


    Worked perfectly for me, no muss no fuss... post and let me know if this helps any of you.
    Ubuntu 11.04 on Work PC, Thinkpad T60, Media PC, and Asus Netbook
    Admin for Ubuntu SERVER 11.04 (x3 production boxes), SERVER 10.10 (x2 production boxes), Ubuntu SERVER 10.04.2 (x3 production boxes)

  10. #10
    Join Date
    Jul 2010
    Location
    Saint-Arnoult, France
    Beans
    3

    Re: Numlock Problem with Logitech MX5500

    HI
    First of all thanks for your help.
    I tried the different solutions proposed here (and yours...) but i'am afraid none of them does work.

    Do you have another Idea ?

    Thx a lot...

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •