Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Unable to get ATI Remote Wonder to Work

  1. #11
    Join Date
    Mar 2007
    Christchurch, NZ

    Re: Unable to get ATI Remote Wonder to Work

    Quote Originally Posted by murbanci View Post
    I dont have /dev/lirc0 so i guess its not even regonizing the reciever. I finally broke down earlier and got a MCE Remote on ebay. It would still be great to get this one to work tho.
    What do you have then? /dev/lirc/0? /dev/lirc1 ?

    Hint, type

    ls /dev/lirc<tab><tab>
    and the shell will show you what options exist.

  2. #12
    Join Date
    Jan 2008

    Re: Unable to get ATI Remote Wonder to Work

    There isnt even a /dev/lirc there is /dev/lircd, however.
    -- Mark
    DVR: Ubuntu 8.10 (Mythbuntu 8.10), Intel Pentium D 3.00 GHz, ASRock 4CoreDual-SATA2, GIGABYTE GV-NX72G512P1 GeForce 7200GS, 2x Seagate Barracuda 250 GB SATA, Western Digital Caviar 1 TB SATA, HP dvd1040i

  3. #13
    Join Date
    Jan 2008

    Re: Unable to get ATI Remote Wonder to Work

    that's what was happening to me too, so it looks like lirc can't find the remote, for whatever reason.

    what do you see in if you do a "cat /var/log/daemon.log | grep lirc" ??

  4. #14
    Join Date
    Feb 2008
    Ubuntu 10.04 Lucid Lynx

    Re: Unable to get ATI Remote Wonder to Work

    hi guys, i've been reading through post after post, thread after thread, trying to get my ati remote wonder working with mythbuntu 8.0.4 as well. i think i've had some success, and would like to share.

    i followed the wiki guide at mythtv for opensuse 10.2:

    however, i made some changes (starting from a clean install and after doing the usual ubuntu updates).

    step 1: instead of blacklisting ati_remote, i blacklisted lirc_atiusb (blacklist lirc_atiusb in /etc/modprobe.d/blacklist)
    step 2: not needed
    step 3: not needed
    step 4: plug it in! (ps -ef | grep lircd should show that lircd is now running)
    step 5: my output looked quite similar
    step 6: not needed
    step 7: i copied the lircd.conf, but instead of /etc/lircd.conf, i modified /etc/lirc/lircd.conf
    step 8: again, i copied the lircrc, but instead of /home/mythtv/.mythtv/lircrc, i modified /home/wmwong/.lirc/mythtv (chown is not required)
    step 9: restart using /etc/init.d/lirc restart
    step 10: should show that lircd is running
    step 11: i know get irw connected and detecting button presses (hit ctrl-c to stop)
    step 12: not needed

    after this, make sure you reboot your system. for me, going right into the frontend DID NOT work. i had to reboot in order for the remote to come alive. i probably could have just restarted the frontend, but i rebooted for safety, and it worked.

    if i go back into the terminal after a reboot, irw now works fine.

    i do notice certain dead keys, but that may just be a key mapping problem?!?! im pretty happy with at least being able to navigate the mythtv menu. i discovered that traveling back to the previous screen on the frontend, i hit 'E' (escape? again, a key mapping issue i hope!) my 'OK' button DOES NOT work at the moment, and i have not tried playing anything yet, as i haven't put anything on the system yet.

    hopefully, that'll get you guys going. if you figure out the key mapping stuff, please do post. this is very frustrating, but at least it looks like there's light at the end of the tunnel!

    good luck!

  5. #15
    Join Date
    Sep 2006

    Re: Unable to get ATI Remote Wonder to Work

    I was able to get it working following this post. Though, yes the mapping is off a little, it works well enough.

    The only key that I have tried and haven't found is the Menu key. The letters hold the clear and pg up pg down buttons, but no menu key. Anyone a) know how to remap, or b) know which one is menu?!?!?

  6. #16
    Join Date
    Jun 2008

    Re: Unable to get ATI Remote Wonder to Work

    I followed the above and finally got farther than any others before that i have tried.

    it all seems to be right but i get no response from front end.
    irw give msgs like 0000001448730000 00 mouse-down ati_remote

    and so on. any ideas as to why front end dosent respond.

    btw before i followed the above i selected ati remote kernel mode in mmc infrared devices

  7. #17
    Join Date
    Sep 2008

    Re: Unable to get ATI Remote Wonder to Work

    just writing to confirm that wmwong's posting helped me a lot:

    in my case I only needed the lircd.conf
    (did not do any blacklist)

    my steps:
    tail -F /var/log/messages
    (plug in usb receiver)
    /var/log/message will reflect that it detected the newly plugged device. (ctrl-c to quit)

    don't know if it's necessary to install lirc but I did:
    sudo apt-get install lirc
    - on the config screen pick ati/nvidia x10 kernel... (don't know if this matters)

    I also restarted lircd a couple of times.

    to confirm that the receiver is receiving message from the remote:
    sudo mode2 --device=/dev/lirc0

    everytime you press a button on the remote, something will show up (ctrl-c to quit)

    this is the point where i got stuck. "irw" does not return anything when I press a button.

    after copying the lircd.conf in the article into my /etc/lircd.conf, and restarting lircd, "irw" now returns something when i press a button.

    I also copied the lircrc in the article into my ~/.mythtv/

    this is on a dell 530 with ubuntu hardy preinstalled.

  8. #18
    Join Date
    Jun 2008

    Re: Unable to get ATI Remote Wonder to Work

    OK got mine working with the above post. I just need better keymappings the top row (tv dvd web menu) dont work but nav arrows at bottom and the play fwd rev work yeah!!

  9. #19
    Join Date
    Jun 2008

    Re: Unable to get ATI Remote Wonder to Work

    anyone get better keymappings for this remote

  10. #20
    Join Date
    Jul 2008
    Southampton, UK
    Lubuntu 12.04 Precise Pangolin

    Re: Unable to get ATI Remote Wonder to Work

    You can generate your own mappings easily enough.

    I guess you want these configured as jumppoints? These are keys that will perform the same function no matter where you are in Myth. I use F5-F8, I think these are set to teletext or subtitle menu colours in Myth, I don't use these, so there's no conflict.

    Edit your lircrc file, and edit the entries for these buttons (or create them if the don't exist).

        prog = mythtv
        button = TV
        config = F5
        repeat = 0
        delay = 0
    Then you'll need to edit the keybindings within Mythtv. Restart LIRC
    sudo /etc/init.d/lirc restart
    ...and Mythfrontend.

    Now go to the 'Edit Keys' menu, It's in one of the setup sub-menu's.

    On the left there is a list of Mythtv states (LiveTV, Program Guide...) one of them will be 'JumpPoints', select this and you will get a list on the right of available Jumppoints, so scroll to the one you want and select it, you will be prompted to press a key. Press the remote key that you want to bind to this function. You will probably get a warning that this conflicts with a global assignment. If you're happy to lose the one it conflicts with, hit enter, else hit esc.

    If you get 'Unknown key pressed' then you haven't got the buttons properly defined, there's probably a naming mismatch between lircd.conf and .lircrc.



Page 2 of 3 FirstFirst 123 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts