Results 1 to 10 of 1210

Thread: Comprehensive ndiswrapper troubleshooting guide

Threaded View

  1. #11
    Join Date
    May 2007
    S. E. Arizona, USA
    Ubuntu 10.10 Maverick Meerkat

    Re: Comprehensive ndiswrapper troubleshooting guide

    First of all congratulations on a masterpiece of a help guide. It is greatly appreciated.

    Of course, in my case it didn't help, which brings me here. I have gotten confusing results, to say the least. The machine is an Acer 5570Z with an Atheros chipset. Identified as an AR5BXB63. I have tried the front panel wireless switch in both positions on each test, and it seems to have little effect on any of the results. The "hardware drivers" screen shows both the Atheros drivers and HAL are installed and active. However, result of the tests were:

    ndiswrapper -l
    This has no output whatsoever.

    $ lshw -C network
    description: Ethernet interface
    product: 88E8038 PCI-E Fast Ethernet Controller
    vendor: Marvell Technology Group Ltd.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: 14
    serial: 00:1b:24:53:21:e8
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical configuration: broadcast=yes driver=sky2 driverversion=1.20 firmware=N/A latency=0 module=sky2 multicast=yes
    description: Ethernet controller
    product: AR242x 802.11abg Wireless PCI Express Adapter vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:03:00.0
    version: 01
    width: 64 bits
    clock: 33MHz
    capabilities: cap_list
    configuration: latency=0

    $ sudo modprobe ndiswrapper
    (This made no difference in any case)

    $ lsmod | grep ndis
    ndiswrapper 192920 0 usbcore 146412 7 ndiswrapper,snd_usb_audio,snd_usb_lib,usbhid,ehci_ hcd,uhci_hcd

    $ dmesg | grep -e ndis -e wlan
    [ 28.151429] wlan: 0.9.4
    [ 181.645518] ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
    [ 181.658114] usbcore: registered new interface driver

    These make it appear to me that the drivers are in place (madwifi 0.9.4) and active. That ndiswrapper is present, and my real problem is that the results of the "dmesg" command looks as it does in your example, but the middle lines of the output are missing. I'm sure this should be pointing me to something, but I don't know what. If this gives a clue what is wrong, I would sure appreciate where to go from here. Anyway, thanks for all the info, it has gotten me further than I have after days and weeks of playing with with. Still no happiness, but I now know a bit more than I did before. Thanks again for any input you might have.


    And as an afterthought, why would Heron have loaded both madwifi and ndiswrapper, as it appears from these responses. I'm sure missing something here.
    Last edited by Manyette; June 29th, 2009 at 03:00 PM.
    // Don
    Toshiba P755-S5390 / Core I7 / 8 gigs


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts