Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 83

Thread: HOWTO: Fix all PulseAudio-related issues in 2 minutes

  1. #21
    Join Date
    Apr 2005
    Location
    C A N A DA
    Beans
    268
    Distro
    Ubuntu

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    I tried this and removed all pulse related packages. I set all my gnome sound settings to use ALSA. After setting everything to ALSA and I hit the TEST button I get no sound. So I tried using "Multichannel Playback" and when I click on the TEST button I hear sound. This leads me to believe that ALSA is working, however it's not working properly when I simply select ALSA. So now this is causing my grief with all my applications which require sound. I've set their output to ALSA and I get no sound.

    I have 2 soundcards and they both show up:
    Code:
    cat /proc/asound/cards
     0 [Audigy2        ]: Audigy2 - Audigy 2 ZS [SB0350]
                          Audigy 2 ZS [SB0350] (rev.4, serial:0x20021102) at 0xe400, irq 21
     1 [ICH5           ]: ICH4 - Intel ICH5
                          Intel ICH5 with AD1985 at irq 23
    I've set my default sound card to the Audigy2.
    Code:
    asoundconf set-default-card Audigy2
    Code:
    cat /proc/asound/modules 
     0 snd_emu10k1
     1 snd_intel8x0
    in my /etc/modprobe.d/alsa-base I have:
    Code:
    options snd_emu10k1 index=0
    options snd_intel8x0 index=1
    any ideas?
    Running: Ubuntu 10.10 & Windows 7 Pro
    Registered Linux User #373810
    Become a Registered Linux User Here.

  2. #22
    Join Date
    Nov 2006
    Location
    India
    Beans
    814

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    Quote Originally Posted by Irihapeti View Post
    Hardly a genius. I just enjoy tinkering with things.

    Irihapeti
    You're Just being modest..Good job though..
    The truth is always beautiful, no matter how ugly it might seem at first.

  3. #23
    Join Date
    Nov 2006
    Location
    San Francisco
    Beans
    164
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    This fix is great. I followed the instructions, rebooted, and now Skype sound is no longer disabled while playing Totem, and Audacity now wonderfully makes use of my USB headset!

    The only problems remaining:

    Skype sound is still disabled if I've routed music output (from Rhythmbox) to my headset and I get an incoming call. Not a big problem, as I'd likely only use my headset for music late at night when I don't want to receive calls.

    But a somewhat bigger issue: This still doesn't work for Flash (for playing videos on YouTube with Firefox) -- it would be nice if there's a solution to this, since my lady sometimes likes to watch YouTube videos while I'm sleeping.
    - Ubuntu 16.04 on 2012 ZaReason, 460GB HD, 8 GB RAM, 3 GHz dual processor -
    - Xubuntu 14.04 on 2003 Sony Vaio laptop, 30GB HD, 1GB RAM, 1.8GHz processor -

  4. #24
    Join Date
    Nov 2006
    Beans
    1,134

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    Quote Originally Posted by grashdur View Post
    Skype sound is still disabled if I've routed music output (from Rhythmbox) to my headset and I get an incoming call.
    This still doesn't work for Flash (for playing videos on YouTube with Firefox) -- it would be nice if there's a solution to this, since my lady sometimes likes to watch YouTube videos while I'm sleeping.
    This can be fixed too.

    The problem is that ALSA defines its default device as a dmix-ed version of the system's first soundcard (hw:0) but doesn't automatically do the same thing for any other card that may be present. However, you can do that yourself, and it's not too difficult.

    I assume the USB headset appears as device hw:1 in the system. Open a text editor and enter or paste the following:
    Code:
    pcm.usbmix {
        type dmix
        ipc_key 1024 # must be unique!
        slave {
            pcm "hw:1,0"
            period_time 0
            period_size 1024
            buffer_size 8192
        }
    }
    
    pcm.usb {
        type plug
        slave.pcm "usbmix"
    }
    Save this as ".asoundrc" in your home folder. Now you have a new PCM device called "usb" which should be capable of handling multiple audio streams simultaneously. Use it instead of hw:1,0.

  5. #25
    Join Date
    Nov 2006
    Location
    San Francisco
    Beans
    164
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    It didn't seem to work: I made that file .asoundrc and I don't see a new device listed in Sound Preferences. I have "USB Audio", which is what I have always selected whenever I want to switch sound output to the headset -- but with YouTube the sound is still going to my speakers. I tried rebooting but it's still the same.
    - Ubuntu 16.04 on 2012 ZaReason, 460GB HD, 8 GB RAM, 3 GHz dual processor -
    - Xubuntu 14.04 on 2003 Sony Vaio laptop, 30GB HD, 1GB RAM, 1.8GHz processor -

  6. #26
    Join Date
    Sep 2008
    Beans
    1

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    Quote Originally Posted by eye208 View Post
    What you will get:
    • Fully functional audio in all applications, including those currently incompatible with PulseAudio (e.g. Audacity, Blender, Skype, Second Life + voice chat, Flash)
    • The ability to use these applications side by side (using software sound mixing provided by ALSA or ESD)

    What you will lose:
    • Ubuntu's login and logout sounds (and any other system sounds you may have added to the default set)


    To implement the fix, perform the following steps:
    1. Open the sound configuration panel (System > Preferences > Sound).
      On the "devices" tab, set all devices to "ALSA".
      On the "sounds" tab, disable "play system sounds".
      Leave "software sound mixing (ESD)" enabled.
      Close the panel.
      (See the attached picture for details.)
    2. Open a terminal window (Applications > Accessories > Terminal).
      Enter the following commands:
      Code:
      sudo apt-get remove pulseaudio
      sudo apt-get install esound
      exit
      -- or --
      Open Synaptic (System > Administration > Synaptic Package Manager).
      Search for the package "pulseaudio" and mark it for removal.
      Search for the package "esound" and mark it for installation.
      Apply the changes, then quit Synaptic.
    3. Restart the computer.


    Remarks:

    This will remove PulseAudio and replace it with ESD. The resulting sound setup will be similar to Ubuntu 7.10 and previous versions. Any issues unrelated to PulseAudio will not be affected in any way.

    To restore the original setup, install the packages "pulseaudio" and "pulseaudio-esound-compat", then re-enable system sounds.
    Hi,

    I did all you suggested but the micro still doesn't work in skype....they can't hear me. all the rest seems to be working smoothly....any other hint? I'm getting desperate....

  7. #27
    Join Date
    Jun 2005
    Location
    Belgium
    Beans
    1,522
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    It is a no go for me. sudo apt-get remove pulseaudio wants to remove ubuntu-desktop as well.
    AMD64X2 3800+ 3GB Ram: 11.10
    ACER one T1810 : 11.10 64 bit

  8. #28
    Join Date
    May 2005
    Location
    Netherlands
    Beans
    155
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    Quote Originally Posted by cotcot View Post
    It is a no go for me. sudo apt-get remove pulseaudio wants to remove ubuntu-desktop as well.
    The ubuntu-desktop package is a meta package meaning that it is used to install the total ubuntu desktop, removing it, however, does not remove the ubuntu (gnome) packages from your system. It is in actual fact quite harmless to do so.

    Just make sure that all it is removing is the ubuntu-desktop meta package and nothing else. You can also find this information in the package description within synaptic.

    I for one don't have it on my system anymore, I think I removed it along with Evolution or some other part of the basic ubuntu install.
    Life is what happens while you're making other plans....
    Desktop: AMD Athlon II x4 635, 4GB, GT240, 1TB
    Laptop: Dell XPS M1330, T5250, 2GB, x3100, 80 GB SSD, 4965AGN

  9. #29
    Join Date
    May 2005
    Location
    Netherlands
    Beans
    155
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    Quote Originally Posted by zamujilo View Post
    Hi,

    I did all you suggested but the micro still doesn't work in skype....they can't hear me. all the rest seems to be working smoothly....any other hint? I'm getting desperate....
    Have you clicked on the 'mic boost' button in volume control? This is something that is often forgotten, but which really is vital!

    Right click on the sound applet in the panel, open volume management or whatever it's called (i'm working in a Dutch version of ubuntu so I couldn't tell you what it's really called, but it's right above 'preferences')

    When the volume management window opens, go into 'edit' and 'preferences'. Select Mic Boost to be visible and then go back and mark it as active in the switches tab of the volume management window.

    Hope that helps! If you've already done all this, than I'm sorry but then I won't be able to help you and I've just wasted your time, sorry about that.
    Life is what happens while you're making other plans....
    Desktop: AMD Athlon II x4 635, 4GB, GT240, 1TB
    Laptop: Dell XPS M1330, T5250, 2GB, x3100, 80 GB SSD, 4965AGN

  10. #30
    Join Date
    Jan 2007
    Beans
    18
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Fix all PulseAudio-related issues in 2 minutes

    I followed the steps, but ALSA cannot play audio.

    audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open audio device for playback.

    asoundconf list displays:
    Names of available sound cards:
    default
    Webcam
    Intel
    HDMI
    I set asoundconfig set-default-card to "Intel", which I would assume is my mobo's on-board sound.

Page 3 of 9 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •