Results 1 to 3 of 3

Thread: Clock ticks fast on Linux guest

  1. #1
    Join Date
    May 2007

    Clock ticks fast on Linux guest

    I've found a few threads about this, but none of them have been sufficient to fix the problem for me it seems.

    I'm using an Ubuntu guest on a Windows XP host and the clock on the guest ticks much faster than it's supposed to. In the other threads I've found about this there were a number of suggestions:

    1) Upgrade your linux kernel, newer versions address this.
    - I'm already using a newer version than the one that was suggested. Mine is 2.6.24-19.generic

    2) Append "clock=pit" or "clock=pmtmr" to the end of the kernel line in the GRUB boot loader configuration file.
    - I've tried both of these, although I believe pmtmr is the default on newer linux kernels. pit seems to be the most accurate

    3) Synchronize time with VMWare Tools.
    - This is currently enabled on my guest.

    Before I did any of this, my clock was ticking at about 1 minute every 10 seconds. Now seems to lose about 1 minute every hour. So this definitely helped but it's still way too fast. Is there anything else I can do? Can I control the interval at which VMWare Tools syncs with the guest? If so I can set it to synchronize with the guest like every 10 minutes or something. It doesn't appera to have synchronized in the past 10 hours.

  2. #2
    Join Date
    Apr 2006
    South Korea
    Ubuntu 8.04 Hardy Heron

    Re: Clock ticks fast on Linux guest

  3. #3

    Re: Clock ticks fast on Linux guest

    Same thing. Tried the suggestions in the link but my clock is running at double speed.

    The article doesn't mention dual or quad core processors. Mine is a quad.
    Intel Core 2 Duo E6600 | Abit IP35 Pro P35
    WD5000AAKS SATA 3.0Gb/s | Creative SB X-Fi XtremeGamer
    OCZ Platinum 2GB DDR2 800 | GeForce 8800GTS 640MB


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts