Right.

I reinstalled Ubuntu.

Followed this thread:

http://ubuntuforums.org/showthread.php?t=684495

then this thread (I opted for the mixed WPA/WPA2 DCHP setting):

http://ubuntuforums.org/showthread.php?t=202834

Bingo.