Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Use google talk with kopete-kde4

  1. #1
    Join Date
    Apr 2007
    Beans
    513

    Use google talk with kopete-kde4

    I have the kde 4.1 repo. I installed kubuntu-kde4-desktop. All went well. I have a perfect kde 4.1 desktop. Only problem is kopete won't work with my google talk account. I have been searching for about an hour and a half and have found no answers. When I try to connect I get this message:
    Code:
    SSL support could not be initialized for account ***************@gmail.com. This is most likely because the QCA TLS plugin is not installed on your system.
    in a popup.
    Ok, so I installed qca-tls and still got the same message. I really do not know where to go from here. Please help.

  2. #2
    Join Date
    Apr 2007
    Beans
    513

    Re: Use google talk with kopete-kde4

    BUMP Please Help!

  3. #3
    Join Date
    Apr 2007
    Beans
    513

    Re: Use google talk with kopete-kde4

    bump!

  4. #4
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Use google talk with kopete-kde4

    Quote Originally Posted by patrickaupperle View Post
    I have the kde 4.1 repo. I installed kubuntu-kde4-desktop. All went well. I have a perfect kde 4.1 desktop. Only problem is kopete won't work with my google talk account. I have been searching for about an hour and a half and have found no answers. When I try to connect I get this message:
    Code:
    SSL support could not be initialized for account ***************@gmail.com. This is most likely because the QCA TLS plugin is not installed on your system.
    in a popup.
    Ok, so I installed qca-tls and still got the same message. I really do not know where to go from here. Please help.
    Are you using port 5223 instead of 5222? If you don't know what I am talking about, go to Settings->Configure and select your gmail id and Modify Account. Go to the Connection tab and make sure that the Overrid default server information is checked, the Server is talk.google.com, and the Port is set to 5223.

    Hope that helps.

  5. #5
    Join Date
    Apr 2007
    Beans
    513

    Re: Use google talk with kopete-kde4

    Quote Originally Posted by Ayuthia View Post
    Are you using port 5223 instead of 5222? If you don't know what I am talking about, go to Settings->Configure and select your gmail id and Modify Account. Go to the Connection tab and make sure that the Overrid default server information is checked, the Server is talk.google.com, and the Port is set to 5223.

    Hope that helps.
    I am pretty sure it is right.

    Yes, I am in gnome right now, same result either way though. I originally found the problem in kde 4. Pidgin works fine, but I really don't like it as well.
    Attached Images Attached Images

  6. #6
    Join Date
    Mar 2007
    Location
    Hamilton, Ohio
    Beans
    50
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Use google talk with kopete-kde4

    this is a problem all the way across the board with kopete. it has nothing to do with kde 3 or 4, as I am running KDE 3.5.9. I recently upgraded to Hardy, and now I cannot connect to Google Talk with kopete, so you're not crazy, at least not in this sense.

    Straight off the kopete.kde.org website:


    Jabber SSL support stopped working, I get the message that the QCA TLS plugin is probably missing. What am I supposed to do?

    As the error message indicates, you are missing the QCA TLS plugin, which handles the Jabber plugin's TLS/SSL encryption. Install the package qca-tls (and eventually qca-ossl) or retrieve the plugin from http://delta.affinix.com/qca. Please note that you only need to install the qca-tls plugin, _not_ the QCA library itself. A recompilation of Kopete is not necessary, in fact not even a restart. In case you have installed the plugin and it still won't work, Qt can probably not find it. Since qca-tls installs itself as a Qt plugin, you will have to make sure that it gets installed to the plugin directory of the Qt version you are using to run Kopete.




    Now, what makes me irritable, is I installed this plugin, and now I get a error saying the jabber server doesn't support the operation.

    I've attached a screengrab of that....

    My settings are exactly the same as my feisty box, talk.google.com, all boxes checked, port 5223, and it connects without any problems...


    Anyone get this to work out there or have we uncovered a <gasp> bug?
    Attached Images Attached Images
    Last edited by netboy541; August 10th, 2008 at 12:19 PM.
    Technology is dominated by two types of people: those who understand what they do not manage, and those who manage what they do not understand.
    My Blog / My Kubuntu Help Blog

  7. #7
    Join Date
    Jul 2008
    Location
    Dayton, Ohio
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Use google talk with kopete-kde4

    Mine works perfect using this fix... a box will pop up about certificate for gmail.com not being verified just click do not show again and then continue... VOILA perfectly working GTALK... Tested using Kubuntu Hardy KDE 4.1

    Code:
    sudo apt-get install qca-tls libqca2-plugin-ossl
    PS set the google talk port to 5223 and enable SSL
    Last edited by Speed Demon; August 11th, 2008 at 02:02 PM.

  8. #8
    Join Date
    Mar 2007
    Location
    Hamilton, Ohio
    Beans
    50
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Use google talk with kopete-kde4

    nope.

    rminick@nomachine1:~$ sudo apt-get install qca-tls libqca2-plugin-ossl
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    qca-tls is already the newest version.
    libqca2-plugin-ossl is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    rminick@nomachine1:~$
    running

    Linux nomachine1 2.6.24-19-server #1 SMP Sat Jul 12 00:40:01 UTC 2008 i686 GNU/Linux
    Hardy
    and kopete 0.12.7
    Technology is dominated by two types of people: those who understand what they do not manage, and those who manage what they do not understand.
    My Blog / My Kubuntu Help Blog

  9. #9
    Join Date
    Mar 2007
    Location
    Hamilton, Ohio
    Beans
    50
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Use google talk with kopete-kde4

    Got it. Change the port from 5223 to 443.

    It connected. yaaaaaaaaaaaaaaaay!

    EDIT : OK, so I thought that worked. It connected once, but won't connect again. hmm...

    well, i switched it back to 5223 and it worked.

    beats the devil out of me.

    thanks tho for reading....
    Last edited by netboy541; August 11th, 2008 at 02:04 AM.
    Technology is dominated by two types of people: those who understand what they do not manage, and those who manage what they do not understand.
    My Blog / My Kubuntu Help Blog

  10. #10
    Join Date
    Jul 2008
    Location
    Dayton, Ohio
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Use google talk with kopete-kde4

    Err...update yo Kopete... i tested on
    Kopete
    Version 0.50.80
    Using KDE 4.1.00 (KDE 4.1.0)

    otherwise... yeah i meant to say put it on 5223 and ssl... on connect it wont verify certificate for gmail.com tell it do not show again and continue and it will work... I hope.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •