EDIT: Though it's not really relevant, what is 'eth1:avahi'? I know it sounds kind of odd, but i've never seen it there until recently - same goes for wmaster0 (when it showed up in iwconfig earlier).
As I understand it, wmaster is a physical interface, while wlan0 is the virtual interface that operates on it--the new Ralink drivers work on this model, instead of just creating one interface in iwconfig per device. I think that eth1:avahi is the same idea. I don't know all of the details, but it's supposed to be this way, so don't worry.
I see that Asus have a linux driver for this adapter listed on their support website - would it be worth trying that at some point? From what I remember, the WL-167g 'just worked' when I plugged it into my machines at 6.04 and 7.10.
Their driver is probably mostly the same as the one that you already tried to compile. Ralink released drivers under the GPL a few years ago, and that's probably the code that Asus has on its website. The driver that I'm trying to have you compile (from http://rt2x00.serialmonkey.com/) is based on the same code but is a little better (more features, support for 64-bit), so I'd stick with that for now.

As for your wireless still not working, it looks like the new driver didn't get compiled or installed correctly for some reason. Please try running the following code again and post the output so that we can check to make sure the new driver is being built properly:
Code:
wget http://rt2x00.serialmonkey.com/rt2570-cvs-daily.tar.gz
tar -xzvf rt2570*
cd rt2570*/Module
make
sudo make install
sudo modprobe rt2570