Results 1 to 3 of 3

Thread: 2.6.24-19 broken - depmod wont complete after update

  1. #1
    Join Date
    Oct 2005
    Location
    Adelaide, Australia
    Beans
    50
    Distro
    Ubuntu 11.04 Natty Narwhal

    Exclamation 2.6.24-19 broken - depmod wont complete after update

    Ran update, as you do to keep up to date with things, it was back when Ubuntu 8.04 moved to kernel 2.6.24-19. Something went wrong (cant remember now) and now I can not get the update-manager to work. update-manager is telling me something is no good and suggests dpkg --configure -a

    when this is executed, depmod starts a my disk makes clicking noise and the console reports a lot of errors.
    Kernel 2.6.24-18 still installed and works just fine and just running depmod -a under that kernel is ok. I can even boot into 2.6.24-19 but sound doesnt work but if I run depmod same errors. thats why I think its more related to the kernel than the disk. I believe the disk is good.

    Now, the only problem is, I cant keep this T40 laptop updated as the package manager thinks packages have not been configured yet.

    Is there anyway to get this fixed or is the recommendation going to be reinstall? I would really prefer to fix than re-install.

    Anyone?

    BTW, I have searched this out and seems others have had issues but none of those fixes have worked for my T40 laptop.
    Any help would be most appreciated.

  2. #2
    Join Date
    May 2008
    Location
    Birmingham, UK
    Beans
    283
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 2.6.24-19 broken - depmod wont complete after update

    You could start by removing the 2.6.24-19 kernel, since that seems to be the problem. If you can use Synaptic Package Manager, search for "2.6.24-19" and select the appropriate packages for removal.

    Then run:
    Code:
    sudo dpkg --configure -a
    and see if you are now able to update successfully.

  3. #3
    Join Date
    Oct 2005
    Location
    Adelaide, Australia
    Beans
    50
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 2.6.24-19 broken - depmod wont complete after update

    Yeah I tried that, with no success the disk started to do the stupid behaviour again.
    I cant keep the box updated if it wont work anymore.

    It seems directly related to that version of kernel ... I think I might start again. I will go with the approach of starting from a fresh install ...

    Time to go back things up .... :-/

    Thanks anyway.

    Brandon.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •