If nothing else will work you could try enter BIOS and make the dvd-drive first-boot and then disable the harddrive as a boot-option. Then it wont boot your windows.. Dont know if this is for any good, but maybe ..

SpiXe - Sorry if ive got a few misspellings