I have read ten or more threads about this problem already but they have not helped. My problem seems to be different. Please read on.

I have a laptop with a GeForce Go video card. I did a fresh install of Hardy and tried to install the Nvidia drivers through the restricted drivers menu; this did not work and the system reverted back to 640x480 resolution. I uninstalled these drivers and then tried using envy. The screen was still in 640x480 mode but after fiddling with my xorg.conf file I was able to get it to let me change to my desired resolution (1440x900). If I run nvidia-settings as root I can save this to my xorg.conf file. However, when I reboot, the resolution goes back to 640x480 after I log in (interestingly, the resolution is correct at the login screen). I have to go into nvidia-settings each time I boot to change back to my desired resolution.

Examining the X11 log file reveals that the nvidia drivers are being loaded without a problem, but at the very last stage (i.e. the last line of the log file) the resolution gets set to 640x480. What's really strange is that if I edit the xorg.conf file or play around with the nvidia-settings tab to force it to boot into 1440x900, I see that it does go into 1440x900 first but then CHANGES BACK to 640x480 right at the end (as recorded by the last line of the log file).

I should also mention that something seems to be messing with my xorg.conf file - If I edit it by hand and save it, it is different the next time I log in.

Any ideas?