Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Kill Switch issue (?) with Intel 4965AGN

  1. #11
    Join Date
    Apr 2008
    Location
    Trondheim
    Beans
    20
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    I dont know what did it in the end, but if you got a file called "rf_kill" in the root dir you can gedit from 0 to 1, and it will work.

    I have done alot of small configurations, but most notably i installed windows on a partition i made with gparted livecd. (In windows i installed the wireless management program that turned on wireless radio in win.)
    That made my ubuntu partition inactive, so i had to install grub with the bootcd. Then i made a windows addition in the grub bootloader menu.lst.

    It is really easier to install windows first, and then ubuntu, but...
    Its a COMPAL IFL90/91 laptop. The software switch isnt working, and the hardware switch has to be turned on.

  2. #12
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    Quote Originally Posted by comradekingu View Post
    I dont know what did it in the end, but if you got a file called "rf_kill" in the root dir you can gedit from 0 to 1, and it will work.
    Hm, running locate rf_kill I didn't find anything, but in searching for rf_kill in the forums led me to /sys/class/net/wlan0/device where I changed 0 to 1 in the rf_kill file. I also tried sudo modprobe ath_pci rfkill=0. Neither of them changed my network from DISABLED.

    I think dmesg reacted in some way, but I'm not sure exactly how.
    Code:
    [  751.089263] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 18 (level, low) -> IRQ 16
    [  751.089331] PM: Writing back config space on device 0000:02:00.0 at offset 1 (was 180002, writing 100006)
    [  753.087692] iwl4965: Wait for START_ALIVE timeout after 2000ms.
    [  753.087765] ACPI: PCI interrupt for device 0000:02:00.0 disabled
    [  753.695283] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 18 (level, low) -> IRQ 16
    .... etc
    And then there's this:
    Code:
    [  920.942563] iwl4965: Error sending REPLY_CARD_STATE_CMD: time out after 500ms.
    [  920.973509] eth0: PHY reset until link up.
    ...
    [  988.804482] ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 18 (level, low) -> IRQ 16
    [  988.804550] PM: Writing back config space on device 0000:02:00.0 at offset 1 (was 180002, writing 100006)
    [  988.805115] iwl4965: Radio disabled by SW RF kill (module parameter)
    [  988.805173] ACPI: PCI interrupt for device 0000:02:00.0 disabled
    This SoftWare Kill (?) must be the change to "1" in rf_kill, right?

    Do you think there's any point for me trying ndiswrapper instead?

  3. #13
    Join Date
    Apr 2008
    Location
    Trondheim
    Beans
    20
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    diswrapper is just a bad solution because its a wrapper that uses the windows version of the intel driver on linux. There isnt a problem with the driver as its already in the kernel.

    The problem is that FN+F2 doesnt work. In windows there is a program that manages the status, and maps fn+f2 to wireless radio killswitch settings.

    Im sorry i cant nail the problem, because i tried lots of such things before getting it to work. Dont know if it was just that final thing that did it or a combination.

    I dont have the laptop in my posession anymore, so i cant run checks on it eighter.
    Last edited by comradekingu; August 24th, 2008 at 03:56 AM.

  4. #14
    Join Date
    Sep 2008
    Beans
    4

    Re: Kill Switch issue (?) with Intel 4965AGN

    I am also having this same issue with the killswitch or Fn+F2 not working. I have a Compal FL92 laptop with the Intel 4965 AGN Wireless card. Turning the killswitch off does disable the wireless but turning it back on does not reenable it. I get the following errors in my messages log.

    Sep 26 11:54:45 jaysens-laptop kernel: [ 198.884501] atkbd.c: Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0).
    Sep 26 11:54:45 jaysens-laptop kernel: [ 198.884511] atkbd.c: Use 'setkeycodes e071 <keycode>' to make it known.

  5. #15
    Join Date
    May 2008
    Beans
    58

    Re: Kill Switch issue (?) with Intel 4965AGN

    If lshw lists the card correctly, and MAC address is displayed alright (I mean not FF:FF:FF:FF:FF:FF) then why not try

    Code:
    sudo ifconfig eth1 up
    I have a similar kill switch problem with my 3945 card. If MAC address is displayed OK, then this way produces positive results. Unfortunately, it does not always displays MAC address correctly.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •