Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: JDK won't work

  1. #21
    Join Date
    Aug 2006
    Location
    Germany
    Beans
    396

    Re: JDK won't work

    I'm still not sure but:
    Those "gcj"-stuff really messes up the java experience of many java "newcomers". I hope open jdk will come to ubuntu soon...and that it will work "better".
    the jvm is my home...
    http://clojure.org/
    http://www.scala-lang.org/...and it rocks a lot!

  2. #22
    Join Date
    Feb 2008
    Beans
    53

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    You are still using the GNU version of the JDK.

    In “Window” > “Preferences” > “Installed JREs” you need to “Add” the Sun JDK and set it as the default.

    The JDK should be in the "/usr/lib/jvm/" folder.
    Thank you.... This worked for me as well

  3. #23
    Join Date
    May 2007
    Beans
    8

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    You are still using the GNU version of the JDK.

    In “Window” > “Preferences” > “Installed JREs” you need to “Add” the Sun JDK and set it as the default.

    The JDK should be in the "/usr/lib/jvm/" folder.
    Words of wisdom. You saved my life there

  4. #24
    Join Date
    Feb 2008
    Location
    The Internet
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: JDK won't work

    Quote Originally Posted by Klayy View Post
    Words of wisdom. You saved my life there
    Mine as well!

  5. #25
    Join Date
    Jun 2006
    Location
    The Netherlands
    Beans
    2,185
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: JDK won't work

    Quote Originally Posted by Shin_Gouki2501 View Post
    I'm still not sure but:
    Those "gcj"-stuff really messes up the java experience of many java "newcomers". I hope open jdk will come to ubuntu soon...and that it will work "better".
    OpenJDK is the default Java on Ubuntu 8.10, and ofcourse it's much better than GNU Java (GCJ).
    Ubuntu 12.04

  6. #26
    Join Date
    Nov 2008
    Beans
    1

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    2 more things to check.

    1. Make sure that the "JRE System Library" is setup as a library for your project.

    Right click your project "Properties" > "Java build path", libraries lab. You should see "JRE System Library..." if you are setup correctly. If not click "Add library" and add "JRE System Library".

    2. Make sure you haven't overridden your workspace complier settings at the project level.

    Right click your project "Properties" > "Java Compiler", make sure that "Enable project specific settings" is NOT checked.

    Good luck
    Thank you so much...

  7. #27
    Join Date
    Oct 2008
    Beans
    31
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    You are still using the GNU version of the JDK.

    In “Window” > “Preferences” > “Installed JREs” you need to “Add” the Sun JDK and set it as the default.

    The JDK should be in the "/usr/lib/jvm/" folder.
    Thank you so much!! Every time I've updated ubuntu I've had to fix this again and have had to just stumble around until I found something that miraculously worked. I'm so glad to have found someone who knows what's going on!

  8. #28
    Join Date
    Nov 2008
    Location
    DK
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    You are still using the GNU version of the JDK.

    In “Window” > “Preferences” > “Installed JREs” you need to “Add” the Sun JDK and set it as the default.

    The JDK should be in the "/usr/lib/jvm/" folder.
    That's just what I was lookin for?

    Thanx a lot

  9. #29
    Join Date
    Mar 2010
    Beans
    1

    Re: JDK won't work

    Quote Originally Posted by tinny View Post
    You are still using the GNU version of the JDK.

    In “Window” > “Preferences” > “Installed JREs” you need to “Add” the Sun JDK and set it as the default.

    The JDK should be in the "/usr/lib/jvm/" folder.
    Thank you so much!!!

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •