Results 1 to 2 of 2

Thread: Setting up multiple bridges

  1. #1
    Join Date
    Mar 2005
    Republic of 1984
    Ubuntu 8.04 Hardy Heron

    Setting up multiple bridges


    I'm trying to setup a dedicated headless VirtualBox server, but need some help with the host networking configuration.

    Is is possible to create multiple bridges that a single physical interface is bound to? i.e.:

    I need host networking on all my virtual machines, so I'm wondering if this is possible in any way or if I'm going about it wrong? Currently I have vbox0-br0-eth0 running, but after I added br1 and tried to addif eth0 to it, obviously I ran into my problem, "device eth0 is already a member of a bridge; can't enslave it to bridge br1."

  2. #2
    Join Date
    Mar 2005
    Republic of 1984
    Ubuntu 8.04 Hardy Heron

    Re: Setting up multiple bridges

    quick update:

    After searching around some more, I decided to simple bring up the additional interfaces in /etc/network/interfaces then bind them all to br0 at once:

    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    auto eth0
    iface eth0 inet manual
    auto vbox0
    iface vbox0 inet manual
    auto vbox1
    iface vbox1 inet manual
    auto vbox2
    iface vbox2 inet manual
    auto br0
    iface br0 inet static
            bridge_ports eth0 vbox0 vbox1 vbox2
            bridge_fd 9
            bridge_hello 2
            bridge_maxage 12
            bridge_stp off
    This works great, except I can't seem to ping from (ubuntu) to (winxp), HOWEVER, I can ping the other way around. 101 will ping to anything else, including other devices on the subnet and the internets.

    My initial thought was to try and put eth0 in promisc as I've seen elsewhere, so I added the following under "iface eth0 inet manual"

    up ifconfig $IFACE up
    up ip link set $IFACE promisc on
    down ip link set $IFACE promisc off
    down ifconfig $IFACE down
    ...which brought everything up as expected, but it didn't seem to fix anything... even after restarting networking on both virtual machines (but not rebooting).

    Any thoughts?

    EDIT: Not sure what happened, but lost connectivity to 45 from every other computer, so decided it was a problem with that VM rather than 101. Several restarts, removed promisc settings, and it occured to me to disable Windows Firewall.... now working!
    Last edited by thegnark; August 19th, 2008 at 01:53 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts