Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: Wireles Running Slowly

  1. #11
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    If you look at the line second from the bottom (bit rates) you'll see that the bit rates (speed) tops out at 11.

    The top speed for 802.11b is 11, the top speed for 802.11g is 54.

    It would appear that this is a 802.11b router or that 802.11g is turned off in the router.
    Good suggestion, but even though transfer rates are capped at 11MB/s (which means download rates of about 1000kb/s), the user should still be seeing much higher download speeds than 40kb/s on the Internet. The 11MB/s limit would really only become a constricting factor if you have an industrial-strength connection to the Internet (most normal residential services only provide up to 3 or 4MB/s, or ~400kb/s) or for transferring information on the internal LAN (e.g. from one computer in your house to another). So I still suspect that signal strength is the issue here.
    Thanks for the response! Unfortunately (unless I did something wrong) it did completely disable my wireless. I took out the three added lines and added back in the one that was removed. How do I add ndiswrapper?
    Sorry it didn't work (I sort of suspected that), but now we can try ndiswrapper. There's a great (if a bit outdated) guide here to using ndiswrapper with Broadcom cards, including your chipset, bcm94311. Unfortunately there are two different models of bcm94311 cards, and the steps that you need to follow are a little bit different depending on which model you have. The output of:
    Code:
    lspci | grep -i 4311
    would tell you which model you have--rev. 01 or rev. 02.

    Once you figure it out, you can follow that guide, or if you prefer, let me know which rev. # you have and I'll write out steps for you (that guide can be a little confusing, and it was written for older versions of Ubuntu, adding to the confusion).

    Remember (the guide may not mention this, since it was not written for Ubuntu 8.04) that in order for ndiswrapper to work, /etc/modprobe.d/blacklist needs to contain these four lines:
    Code:
    blacklist b43
    blacklist b43legacy
    blacklist ssb
    blacklist bcm43xx
    Also remember that if you're using a 64-bit Linux kernel, the Windows drivers that you load into ndiswrapper need to also be 64-bit (I think the guide above doesn't mention this at all and just assumes that everyone is using 32-bit). If you're on 64-bit, let me know.

  2. #12
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    Thanks, I'll try this before shelling out the money for a new router. If you have the time, and it won't be too much trouble, it would be awesome if you could give me the steps on what to do. I'm pretty comfortable with guides but I have had problems in the past following guides meant for older releases. Also note that I undid everything to the blacklist file that you had me do earlier (removed the three lines I added and added back in the line I deleted) so if I need to do that again let me know.

    Code:
    joshua@SNKNGSHPS:~$ lspci | grep -i 4311
    05:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

  3. #13
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    I've got this same issue; I have a year-old Toshiba Satellite A205-S4617 with an Intel 4695 AG Card...my out puts are as follows:
    Your card has a completely different chipset, so none of this Broadcom/ndiswrapper stuff applies.

    I don't know so much about Intel wireless, as I don't own any Intel cards myself, but I found this thread where some people with the same card as you mention similar problems; this bug report also seems related. The solution is supposed to be to upgrade to the latest release of the driver. So first of all, you should apply all Ubuntu updates and see if that fixes the problem--chances are that it will.

    If not, follow these instructions for compiling the latest wireless drivers from source. If you need help, or if the problem persists even with the newer drivers installed, you may want to start a new thread (and let us know the URL) so that your problem doesn't get tangled up with the problem of the original poster here.

  4. #14
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    I also forgot to mention, I am running 32-bit and I just added
    Code:
    blacklist b43
    blacklist b43legacy
    blacklist ssb
    blacklist bcm43xx
    To the blacklist file.

  5. #15
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    If you have the time, and it won't be too much trouble, it would be awesome if you could give me the steps on what to do.
    Sure, it's not a problem. Since you've already dealt with the blacklist issue, you need to run just these commands to get it to work (these assume that you are plugged in to the Internet via ethernet; if that's impossible, let me know):
    Code:
    sudo apt-get install cabextract ndiswrapper*
    wget ftp://ftp.compaq.com/pub/softpaq/sp34001-34500/sp34152.exe
    cabextract sp34152.exe
    sudo ndiswrapper -i bcmwl5.inf
    ndiswrapper -l
    sudo depmod -a
    sudo modprobe ndiswrapper
    sudo cp /etc/network/interfaces /etc/network/interfaces.orig
    echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
    sudo ndiswrapper -m
    echo 'ndiswrapper' | sudo tee -a /etc/modules
    echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant
    If you get error messages at any point, please post them here. Otherwise, at this point, you should see wireless networks listed when you click on the Network Manager icon. If not, try rebooting and then run these commands:
    Code:
    sudo rmmod ndiswrapper
    sudo rmmod ssb
    sudo modprobe ndiswrapper
    and wait a few seconds to see if networks become visible.

    If you still don't have luck, please post the output of:
    Code:
    ndiswrapper -l
    iwconfig
    lshw -C Network
    cat /etc/modprobe.d/blacklist
    iwlist scan

  6. #16
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    Thanks so much for that! I'm at work at the moment, I have been connecting to my computer via remote desktop, but it is connected wirelessly at the moment so I won't be able to test this out until I get home and connect it by an ethernet cable. Thanks again!

  7. #17
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    I followed everything and there were no errors. I'm connected wirelessly right now and everything seems to be running smoothly. I haven't tried to do any heavy downloading or anything yet but hopefully this will clear it all up. Thanks for your help!! Do you think trying to eventually get a wireless-g router would still help the speed or would it be about the same on this driver for both routers?

  8. #18
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    I'm glad you got it working. Let me know if the download speeds are better (and if they're not, please post the output of "lshw -C Network" so that we can make sure that your system is indeed using ndiswrapper right now instead of b43).

    I don't think that a wireless G router will make much of a difference for you. Wireless range is a little better under the G protocol, but in terms of downloading stuff from the Internet, as I said in an earlier post, the maximum download speed available from your ISP is never going to be more than a fraction of what your router can transmit, even in B mode. If you transfer large files between computers on your home LAN, then G mode would make the transfers much faster, but that's the only case where I can see it making a big difference.

    Actually I had my home network accidentally operating under B mode for several months because I changed the setting to test something and forgot to change it back. I only realized that I wasn't in G mode when I happened to notice it in the router configuration utility many months later. In other words, for me, there was no perceivable difference between B and G modes.

    Anyway G mode is becoming outdated now as N mode (which is a lot faster and has a much wider range) is being introduced; you may be better off holding out until N becomes widespread and routers that support it become cheaper, and then get one of them.

  9. #19
    Join Date
    Mar 2008
    Beans
    168
    Distro
    Hardy Heron (Ubuntu Development)

    Re: Wireles Running Slowly

    Well I haven't noticed it going any faster so I ran "lshw -C Network" and it looks like it's still using that old driver. I didn't notice any errors when following your instructions from earlier, but maybe I missed them?

    Code:
    joshua@SNKNGSHPS:~$ lshw -C Network
    WARNING: you should run this program as super-user.
      *-network               
           description: Network controller
           product: BCM94311MCG wlan mini-PCI
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:05:00.0
           version: 01
           width: 32 bits
           clock: 33MHz
           capabilities: bus_master cap_list
           configuration: driver=b43-pci-bridge latency=0 module=ssb
      *-network
           description: Ethernet interface
           product: BCM4401-B0 100Base-TX
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:08:00.0
           logical name: eth0
           version: 02
           serial: 00:1c:23:87:6f:c9
           width: 32 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical
           configuration: broadcast=yes driver=b44 driverversion=2.0 latency=64 module=ssb multicast=yes
      *-network
           description: Wireless interface
           physical id: 1
           logical name: wlan0
           serial: 00:1b:fc:82:56:37
           capabilities: ethernet physical wireless
           configuration: broadcast=yes ip=192.168.1.106 multicast=yes wireless=IEEE 802.11g

  10. #20
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireles Running Slowly

    hmmm, the lshw output is a bit strange; I'm not sure which driver it's using (it seems to think that you have two different wireless cards but I think it's due to confusion). To figure out which device you're actually using, what does:
    Code:
    ifconfig
    say?

    Also, to double-check that b43 and friends are all blacklisted correctly, what does:
    Code:
    cat /etc/modprobe.d/blacklist
    yield?

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •