Hi guys.

So i'm pretty new to ubuntu, and have been pretty lucky till today. I've been able to solve all my problems via the forums or some good googling...

But yesterday, during a list of twelve or so updates, my computer crashed or froze or something... and i went ahead and restarted my laptop. but now i'm getting an error message reading:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E:_cache->open() failed, please report.
I've figured out that i have to run 'sudo dpkg --configure -a', however, when i do this my terminal reads:

Setting up linux-image 2.6.24-19-generic (2.6.24-19.36) ...
Running depmod.
AND IT STAYS THERE.
what the *bleep* is depmod? what should i do? any advice is apreciated...