Results 1 to 4 of 4

Thread: Could not acquire compositing manager selection on screen 0 display ":1.0"

  1. #1
    Join Date
    Aug 2007
    Location
    Glasgow, Scotland
    Beans
    25
    Distro
    Ubuntu 8.04 Hardy Heron

    Angry [Solved] Could not acquire compositing manager selection on screen 0 display ":1.0"

    Ok, probably this has been discussed, but I actually couldnt find an answer anywhere to my problem.

    When I run compiz I get this error

    Code:
    compiz (core) - Error: Could not acquire compositing manager selection on screen 0 display ":1.0"
    compiz (core) - Fatal: No manageable screens found on display :1.0
    I have a Toshiba Satellite Pro laptop with an ATI graphics card. Not sure which one, and can't remember how to work it out, so if you need it to work out whats wrong, tell me a command to find it out.

    My xorg.conf

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	Defaultdepth	24
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"fglrx"
    	Option		"VideoOverlay"	"on"
    	Option		"OpenGLOverlay"	"off"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"gb"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"	"/dev/psaux"
    	Option		"Protocol"	"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen "Default Screen"
    	Inputdevice	"Synaptics Touchpad"
    EndSection
    
    Section "Module"
    	Load		"glx"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    *EDIT* I have solved this, look at my next post *EDIT*
    Last edited by ya-manickill; August 12th, 2008 at 10:36 PM. Reason: Solved

  2. #2
    Join Date
    Feb 2008
    Beans
    4

    Re: Could not acquire compositing manager selection on screen 0 display ":1.0"

    same two error with my intel integrated graphics card......anybody here to help?????

  3. #3
    Join Date
    Aug 2007
    Location
    Glasgow, Scotland
    Beans
    25
    Distro
    Ubuntu 8.04 Hardy Heron

    Smile [Solved] Re: Could not acquire compositing manager selection on screen 0 display ":1.

    Ok, I got this to work. Basically, my problem was that Compiz couldn't manage to find the compositing manager from Metacity. So basically you have to disable the Metacity compositing manager.

    I cannot remember how to do this, but I'm sure you can find someone. If not, I'll try and remember how I did it, and then I will post back with that. Hope that's good.


  4. #4
    Join Date
    Aug 2006
    Location
    Messina, Italy
    Beans
    98
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: [Solved] Re: Could not acquire compositing manager selection on screen 0 display

    I hope you already found the solution!!! However for who as me who come here the solution is shown in bug #178953 post

    Code:
    gconftool-2 --type bool --set /apps/metacity/general/compositing_manager false
    rgds
    Registered Linux User #426115
    My personal blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •