Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Setup Nvidia XConfig

  1. #1
    Join Date
    Apr 2008
    Beans
    57

    Setup Nvidia XConfig

    I'm trying to repair my nvidia settings. I am unable to change my screen resolution. I have the nvidia 'latest' driver, as well as the nvidia settings app. My problem is the 'latest' driver doesn't seem to have an xconfig ability, and if I repair that, i lose the 'latest' driver, all the while still unable to change resolution. Please help.
    My son is serving proudly in the US Air Force!

  2. #2
    Join Date
    Jun 2006
    Location
    Texas
    Beans
    3,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Setup Nvidia XConfig

    Running Hardy?
    What's the new sudo dpkg-configure xserver-xorg

    Take a look at post #5. That worked for me on 2 PCs.
    UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things. -- Doug Gwyn
    SystemRescueCd | Dual Boot | psychocats | FAQ

  3. #3
    Join Date
    Apr 2008
    Beans
    57

    Re: Setup Nvidia XConfig

    I tried the above, and I guess what I need is the Nvidia X driver? What is that and how do I get it? I can't tell in synaptic which one I need.
    My son is serving proudly in the US Air Force!

  4. #4
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Setup Nvidia XConfig

    Which driver are you running exactly ?

    Easiest way to configure is to :

    Code:
    nvidia-xconfig
    Or

    Code:
    gksu nvidia-settigns
    Save your changes and re-start X

    You *may* need to sudo apt-get install nvidia-settings
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  5. #5
    Join Date
    Apr 2008
    Beans
    57

    Re: Setup Nvidia XConfig

    nvidia-xconfig:
    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'

    gksu nvidia-settings:

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the server.

    nvidia-xconfig:

    Using X configuration file: "/etc/X11/xorg.conf".
    ERROR: Unable to write to directory '/etc/X11'.

    Now I'm lost as a cow at a square dance.
    My son is serving proudly in the US Air Force!

  6. #6
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Setup Nvidia XConfig

    What nvidia driver are you using ?

    If you just installed the nvidia driver, reboot

    Otherwise, there is nothing wrong with the nvidia-xconfig command.

    You need to re-start X now, that means log out and back in or Ctrl-Alt-Backspace

    If you need further adjustments use gksu nvidia-settigns
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  7. #7
    Join Date
    Apr 2008
    Beans
    57

    Re: Setup Nvidia XConfig

    Driver = NVidia 'latest'

    When I try to run the Nvidia settings, I get:

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration...

    When I try to do that, as root, I get:

    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    My son is serving proudly in the US Air Force!

  8. #8
    Join Date
    Jun 2006
    Location
    Texas
    Beans
    3,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Setup Nvidia XConfig

    Unfortunately I have 3rd PC with a Nvidia FX5200 card. Its an older P2-400mHz - 384MB ram. Just a play and test PC.
    Its has me running in circles.
    I go into System>Adminstration>Hardware Drivers and enable the Nvidia Driver. It comes back and tells me I need to restart.
    I restart and get a blank screen.
    I press Ctrl+Alt+F1 to bring up tty1 logon and enter sudo reboot
    It reboots and I select recovery mode from the Grub Menu
    I select xfix then select resume normal boot.
    Gui come up with a 600x800 resolution.

    Wait I'm going to try something else
    Code:
    gksudo nvidia-xconfig
    be back in a bit and let you know how it went.
    Last edited by louieb; July 25th, 2008 at 01:44 AM.
    UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things. -- Doug Gwyn
    SystemRescueCd | Dual Boot | psychocats | FAQ

  9. #9
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Setup Nvidia XConfig

    Quote Originally Posted by knudsenjoe View Post
    Driver = NVidia 'latest'

    When I try to run the Nvidia settings, I get:

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration...

    When I try to do that, as root, I get:

    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    As I said, there is nothing wrong with that. That output is normal and is telling you a new X config file was make and the old one was backed up.

    Did you restart X ?

    And what is "NVidia latest" ?? I am not familiar with that terminology. What is "nvidia latest", where did you get it from, and how did you install it ?
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  10. #10
    Join Date
    Apr 2008
    Beans
    57

    Re: Setup Nvidia XConfig

    I'm using the nvidia 'latest' video card driver. I mention it in case it helps. I am stuck though, can't figure this out.
    My son is serving proudly in the US Air Force!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •