Results 1 to 1 of 1

Thread: nForce 780a: dmraid doesn't recognize SATA raid array

  1. #1
    Join Date
    Sep 2007

    Thumbs down nForce 780a: dmraid doesn't recognize SATA raid array


    I have run into trouble while trying to install Ubuntu 8.04 AMD64 onto a rig with an ASUS M3N-HT Deluxe mobo, sporting an NVIDIA nForce 780a chipset which supports SATA fakeraid, with two Seagate Barracuda ES.2 500GB drives configured as RAID 0 array. The raid is confirmed to work (Windows 2008 installed). Ubuntu fails me though. BIOS setting for the controller is "raid" btw.

    Here's what I did so far:
    • Since Ubuntu has trouble identifying any of my SATA drives including the disk drive, I boot off the AMD64 live cd with additional parameter pci=nomsi which I found here in the forums. all_generic_ide didn't do anything for me. I remove the two silent options to see what the system actually does.
    • The live cd boots, but I get errors about the HDDs being read beyond their limit.
    • GPartEd shows only the two HDDs.
    • I install dmraid.
    • dmraid -r lists the drives correctly, both showing the same nvidia_somestring identifier.
    • dmraid -s shows the nvidia_somestring set.
    • dmraid -ay does not return any message.
    • I run dmraid -s again. The set is not shown as active.
    • I check the contents of /dev/mapper. There's only the default item (control, I think it was), but not the nvidia_somestring.
    • GPartEd still only shows the individual disks.
    • Nothing in /var/log/ shows anything out of the ordinary.
    • I try dpkg-reconfigure dmraid which is successful, repeat above steps. No change.

    I tried the same with an Intrepid nightly live cd and a 8.04 32-bit live cd, same result.

    [edit] Out of desperation I tried a Fedora 9 live cd (64-bit). Same problem, although I got an error message "I/O error, dev sr0" that I didn't get with Ubuntu. The raid set still wouldn't activate, just as under Ubuntu. [/edit]

    What else could I try?


    Last edited by silanea; July 22nd, 2008 at 09:47 PM. Reason: New information


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts