Hello, I am running into a problem simliar to this. I have had ubuntu installed for a few weeks now, and everything was working fine. I was playing a video game, talking to a friend on jabber (pidgin) and all of a sudden, the game freezes and things start to mess up. i tried opening the system manager, but got an error, so i tried to log out, but it wasn't working so I CTRL+ALT+BKSPACEd and then my computer completely froze. now when I try to boot up I get the same thing as the OP.

So, i tried to boot in safe mode or whatever it is on the options under kernels and there are some lines about not being able to mount various things. a few of the lines:

mount: Mounting /dev/disk/by-uuid/7f6aaeb3-1ca7-4ada-aac8-f4e40d3020f5 on /root failed: Invalid argument
Begin: Running /scripts/local-bottom ...
Begin: Running /scripts/init-bottom ...
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root/proc failed: No such file or direcotry
Target filesystem doesn't have /sbin/init
no part of that sounds particularly good to me. So I ran the lines suggested by ago.

cat /proc/cmdline
root=uuid=7f6aaeb3-1ca7-4ada-aac8-f4e40d3020f5 ro single
cat /proc/mounts
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid.nodev,noexec 0 0
none /proc proc rw,nosuid,nodev,noexec 0 0
udev /dev tmpfs rw,relatime 0 0
fusect1 /sys/fs/fuse/connections fusect1 rw,relatime 0 0
cat /proc/parititions
major minor  #blocks  name

   8     0   58605120 sda
   8     1   56163208 sda1
   8     2          1 sda2
   8     5    2441848 sda5
i hope you guys can help me :downs: