Hi all, I've spent countless nights reading the crap out of the tx2000 threads. (my problem is explained after some details)

I've got a tx2110us:
64 X2 TL 62 2.10GHz
Wacom Digitizer Tablet Screen
3GB Ram
250GB Hdd
nVidia 6150 Go 256MB
Vista 64bit/Ubuntu 8.04

Here's what i've gotten to work:
Wifi - ndiswrapper
Bluetooth - out of the box
Video - Proprietary drivers
Wacom Digitizer Tablet Screen - linuxwacom 0.8.0-3 (no patch)
Sound - Intel drivers
Suspend/Hibernate (threads on here explain how to)
Screen Rotate hack using the Quickplay button

I haven't been able to configure the touch portion of the screen, don't really use that feature a lot because it doesn't work so well, the pen calibration is perfect upon install.

Here is my xorg.conf:
PHP Code:
    # xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

# added
Section "InputDevice"
        
Driver          "wacom"
        
Identifier      "TabletPCStylus"
        
Option          "Device"        "/dev/input/by-id/usb-Tablet_ISD-V4-event-mouse"
        
Option          "Type"          "stylus"
    
Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
        
Option          "USB"           "on"
EndSection
Section 
"InputDevice"
        
Driver          "wacom"
        
Identifier      "TabletPCStylus2"
        
Option          "Device"        "/dev/input/by-id/usb-Tablet_ISD-V4-event-mouse"
        
Option          "Type"          "eraser"
    
Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
        
Option          "USB"           "on"
EndSection
Section 
"InputDevice"
        
Driver          "wacom"
        
Identifier      "TabletPCStylus3"
        
Option          "Device"        "/dev/input/by-id/usb-Tablet_ISD-V4-event-mouse"
        
Option          "Type"          "cursor"
    
Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
        
Option          "USB"           "on"
EndSection
Section 
"InputDevice"
    
Driver        "wacom"
    
Identifier    "pad"
    
Option        "Device"    "/dev/input/by-id/usb-Tablet_ISD-V4-event-mouse"
    
Option        "Type"        "pad"
    
Option        "USB"        "on"
EndSection
# end added

Section "InputDevice"
    
Identifier    "Generic Keyboard"
    
Driver        "kbd"
    
Option        "XkbRules"    "xorg"
    
Option        "XkbModel"    "pc105"
    
Option        "XkbLayout"    "us"
EndSection

Section 
"InputDevice"
    
Identifier    "Configured Mouse"
    
Driver        "mouse"
    
Option        "CorePointer"
EndSection

Section 
"InputDevice"
    
Identifier    "Synaptics Touchpad"
    
Driver        "synaptics"
    
Option        "SendCoreEvents"    "true"
    
Option        "Device"    "/dev/psaux"
    
Option        "Protocol"    "auto-dev"
    
Option        "HorizEdgeScroll"    "0"
EndSection

Section 
"Device"
    
Identifier    "Configured Video Device"
    
Driver        "nvidia"
    
Option        "NoLogo"    "True"
    
Option        "RandRRotation"    "on"
EndSection

Section 
"Monitor"
    
Identifier    "Configured Monitor"
EndSection

Section 
"Screen"
    
Identifier    "Default Screen"
    
Monitor        "Configured Monitor"
    
Device        "Configured Video Device"
    
Defaultdepth    24
EndSection

Section 
"ServerLayout"
    
Identifier    "Default Layout"
    
screen "Default Screen"
    
Inputdevice    "Synaptics Touchpad"        
    
Inputdevice     "TabletPCStylus"        "SendCoreEvents"
    
Inputdevice     "TabletPCStylus2"       "SendCoreEvents"
    
Inputdevice     "TabletPCStylus3"       "SendCoreEvents"
    
Inputdevice     "pad"
EndSection
Section 
"Module"
    
Load        "glx"
EndSection 
My issue is that when I'm using the pen, it hovers great, I can click on icons/buttons fine, however when I'm using gimp the pressure sensitivity seems to be backwards or something. If I press real hard no drawing occurs, if I press lightly the pressure works unless I press to hard.


I haven't applied any patches to the linuxwacom libraries, does this patch resolve this issue, does anyone know what the patch is for?

I've only read about the patch being applied to the 7 series of the linuxwacom libraries, not the 8 series.

The 7 series of the linuxwacom libraries didn't work on my tablet for some reason when following the instructions of some of the threads on here.

I've tried to use /dev/input/wacom in my xorg.conf but upon restart I get no tablet functionality working at all. Most likely because i'm using 8 series linuxwacom libraries but I thought I would at least make mention of this.

If some kind person could help me come up with a solution to my issue then I can finally get rid of windows vista completely and just use wine/qemu to run visual studio and some other various apps as i'm a software engineer.

Thanks,
Brian