Results 1 to 3 of 3

Thread: Totem, Mplayer crash on X error "insufficient resources"

  1. #1
    Join Date
    Feb 2005
    Christchurch, New Zealand

    Totem, Mplayer crash on X error "insufficient resources"

    All video programs crash with the error "X11 error: BadAlloc (insufficient resources for operation)" when I play video > 640x480 (eg. DVD, DV) - Totem, mplayer, xine, vlc, avidemux, kdenlive, they all crash.

    This is not a physical limitation of the laptop - these programs all worked fine under Feisty, and I was a happy little DVD viewer. It fell apart with the Gutsy upgrade, I believe. Mplayer can play DVDs (barely) with the -vo x11 option (this is an xv problem), but the laptop doesn't really have the snot for that - I need this graphic chip working.

    The laptop has a SiS chipset. I have just done a fresh install of Ubuntu Hardy. Interestingly, there is now no reference to SiS in xorg.conf at all. Looks like Xorg is doing it all automatically, clever wee thing:

    $ grep -i SIS /var/log/Xorg.0.log
    (--) PCI:*(1:0:0) Silicon Integrated Systems [SiS] 630/730 PCI/AGP ...
    (--) SIS(0): VideoRAM: 8192 KB
    (II) SIS(0): Using 4096K of framebuffer memory at offset 0K
    (--) SIS(0): Hardware supports two video overlays

    This kind of all looks OK to me.


  2. #2
    Join Date
    Feb 2005
    Christchurch, New Zealand

    Thumbs down Re: Totem, Mplayer crash on X error "insufficient resources"

    Tried these, without success:

    1. Can't set the video memory from the bios - it seems to be permanently set at 8Mb
    2. Lowering the resolution with xrandr didn't help - not even 640x480
    3. Turning off extension MIT-SHM in xorg.conf didn't help
    4. mplayer -vo sdl didn't help

  3. #3
    Join Date
    Aug 2008
    Altrincham, UK
    Ubuntu 8.04 Hardy Heron

    Re: Totem, Mplayer crash on X error "insufficient resources"

    I have just fixed this problem on my own machine (Sony Vaio T1XP).
    I discovered I had caused it myself by trying to get rid of the message "opera: X Shared memory extension is not available. ZPixmap not supported"

    I got rid of the error message above by adding the following to my /etc/X11/xorg.conf file:
    #Section "Device"
    # Identifier "Configured Video Device"
    # Option "AccelMethod" "XAA" #not EXA

    This worked, but left me with the same problem you found. Commenting out my own code block, and restarting gdm, had mplayer working again. I guess I am using EXA now.

    I can live with the error message. It has no detrimental effect, I was just being tidy.

    Tim Crumpton, Altrincham

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts