Quote Originally Posted by TimSylvester View Post
Yes, that did it. Thanks!

For the record, I added "rootflags=barrier=0" to the kernel command line. ("nobarrier" seems to be the XFS equivalent). Next step is to update grub2 so it happens automatically...
I'm having the same issue: remountrw appears to "work" although no changes are committed after a reboot.

cat /proc/mounts (before remountrw):
Code:
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev tmpfs rw,relatime,mode=755 0 0
/dev/disk/by-uuid/2f4daaaa-ec96-426c-be68-f4bb6bfe4166 /ro ext4 ro,relatime,barrier=0,data=ordered 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
aufs-tmpfs /rw tmpfs rw,relatime 0 0
aufs / aufs rw,relatime,si=82ce0764d1af8a79 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
tmpfs /tmp tmpfs rw,relatime 0 0
none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
none /lib/init/rw tmpfs rw,nosuid,relatime,mode=755 0 0
tmpfs /var/log tmpfs rw,relatime 0 0
tmpfs /var/tmp tmpfs rw,relatime 0 0
tmpfs /var/lib/dhcp3 tmpfs rw,relatime 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfs-fuse-daemon /home/cmhaadmin/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
Here's what it looks like after running remountrw:

Code:
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev tmpfs rw,relatime,mode=755 0 0
/dev/disk/by-uuid/2f4daaaa-ec96-426c-be68-f4bb6bfe4166 /ro ext4 rw,relatime,barrier=0,data=ordered 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
aufs-tmpfs /rw tmpfs rw,relatime 0 0
aufs / aufs rw,relatime,si=82ce0764d1af8a79 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
tmpfs /tmp tmpfs rw,relatime 0 0
none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
none /lib/init/rw tmpfs rw,nosuid,relatime,mode=755 0 0
tmpfs /var/log tmpfs rw,relatime 0 0
tmpfs /var/tmp tmpfs rw,relatime 0 0
tmpfs /var/lib/dhcp3 tmpfs rw,relatime 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfs-fuse-daemon /home/cmhaadmin/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
As you can see, the rw flag is set after remounting, but making changes doesn't commit (I tried 'touch foobar' in my sudo user's home directory, and then running remountro and rebooting).

My grub.cfg has been edited manually (that was another adventure altogether) for now, will fix once I have this working.

Here's my grub.cfg:

Code:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
  have_grubenv=true
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  saved_entry=${prev_saved_entry}
  save_env saved_entry
  prev_saved_entry=
  save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 2f4daaaa-ec96-426c-be68-f4bb6bfe4166
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###



### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

# aufs read-only grub menu items
menuentry "Ubuntu, Linux 2.6.31-20-generic READ-ONLY" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        set quiet=1
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 2f4daaaa-ec96-426c-be68-f4bb6bfe4166
        linux   /boot/vmlinuz-2.6.31-20-generic root=UUID=2f4daaaa-ec96-426c-be68-f4bb6bfe4166 ro quiet splash aufs=tmpfs rootflags=barrier=0
        initrd  /boot/initrd.img-2.6.31-20-generic
}

menuentry "Ubuntu, Linux 2.6.31-20-generic WRITEABLE" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        set quiet=1
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 2f4daaaa-ec96-426c-be68-f4bb6bfe4166
        linux   /boot/vmlinuz-2.6.31-20-generic root=UUID=2f4daaaa-ec96-426c-be68-f4bb6bfe4166 ro quiet splash
        initrd  /boot/initrd.img-2.6.31-20-generic
}


menuentry "Ubuntu, Linux 2.6.31-20-generic (recovery mode)" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
        insmod ext2
        set root=(hd0,1)
        search --no-floppy --fs-uuid --set 2f4daaaa-ec96-426c-be68-f4bb6bfe4166
        linux   /boot/vmlinuz-2.6.31-20-generic root=UUID=2f4daaaa-ec96-426c-be68-f4bb6bfe4166 ro single
        initrd  /boot/initrd.img-2.6.31-20-generic
}

### END /etc/grub.d/40_custom ###



### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
        linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
        linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ ${timeout} != -1 ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###