Page 5 of 5 FirstFirst ... 345
Results 41 to 42 of 42

Thread: How do you remove MESA drivers?

  1. #41
    Join Date
    Jul 2008
    Beans
    121

    Re: How do you remove MESA drivers?

    Quote Originally Posted by PeterP24 View Post
    Hi! I've tried everything:
    - through the restricted drivers manager (the easy way);
    - through envy;
    - manualy with the latest driver from ATI.

    Meanwhile, since the latest post, I got it fixed (many thanks to saltedlight - from the IRC channel ubuntu-ro).
    The method -> use the following commands:

    sudo apt-get update
    sudo apt-get install linux-restricted-modules-generic

    sudo apt-get install xorg-driver-fglrx
    sudo depmod -a

    sudo dpkg-reconfigure -phigh xserver-xorg

    sudo nano /etc/X11/xorg.conf

    Until here you probably tried already. By the way if a message is thrown that linux-restricted-modules-generic and xorg-driver-fglrx packages are already installed is ok. Just ignore and go ahead. Next in the xorg.conf, at the Device section I wrote

    Device "vesa"

    (instead of the classical Device "fglrx")

    You save and exit (Ctrl o and exit Ctrl x)and then :

    sudo aticonfig --force --initial

    You must reboot the computer and after the reboot go to restricted drivers manager (hardware drivers) and install the ATI driver. After that reboot again.

    As you see there are little differences from the original guide for Hardy. These steps may appear silly (installing first vesa and then the ATI driver) but they worked for me after 3 days of trials - in this time I've tried everything I could find on the internet for Hardy. I wanted to post it, maybe it will help you too.

    Best regards,

    Peter
    I may try that. Could you put the command fglrxinfo into the terminal and make sure that you are using the ATI drivers for OpenGL rendering? If it returns Mesa, we still have problems. If it returns ATI, we may have just solved a four page thread.
    In DOS, no one can hear you click.

  2. #42
    Join Date
    Aug 2007
    Beans
    190
    Distro
    Ubuntu

    Re: How do you remove MESA drivers?

    root@MartinEden:/lost+found# fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon Xpress Series
    OpenGL version string: 2.1.7412 Release
    As I pointed out this is the ATI driver from the Ubuntu repositories (not the latest).

    To be sure I tested it with the Open Arena game - it works fine. On my computer Open Arena won't start with mesa.

    Peter

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •