Results 1 to 2 of 2

Thread: git-daemon + iptables + xinetd

  1. #1
    Join Date
    Jul 2006
    Location
    Hamburg, Germany
    Beans
    32
    Distro
    Ubuntu 10.10 Maverick Meerkat

    git-daemon + iptables + xinetd

    What I want: To set git repos on my server
    What I am using: xinetd, so that when people try and connect it gives them the git service
    My problem: I am using iptables to block everything except port 80 (webserver), (2899 my alternate ssh server port) and now 9418 (which is what I thought that git uses).

    This is what my git-daemon file under /etc/xinet.d/ looks like

    # default: off
    # description: The git server offers access to git repositories
    service git
    {
    disable = no
    type = UNLISTED
    port = 9418
    socket_type = stream
    wait = no
    user = nobody
    server = /usr/local/bin/git-daemon
    server_args = --inetd --export-all --base-path=/var/www
    log_on_failure += USERID
    }


    But whenever I try and connect to my server I look in my logs and see that iptables is blocking a connection trying to be made on port 32767

    I am not quite sure why this is. All I want is to open up my firewall enough so that I can pull and push stuff to my git repos on my server.

    Any help appreciated.

  2. #2
    Join Date
    Jun 2011
    Beans
    5

    Re: git-daemon + iptables + xinetd

    Wow this is an old thread, but hopfully someone sees this.

    I have been trying something similar, and I think my problem lies in how i'm writing my /etc/xinetd.d/git-daemon file. can someone post their configueration? I'd like to compare it to mine.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •