Results 1 to 7 of 7

Thread: [SOLVED] Error 17, 22 in GRUB...partitioning too

Threaded View

  1. #1
    Join Date
    Jun 2008
    Ubuntu 9.04 Jaunty Jackalope

    [SOLVED] Error 17, 22 in GRUB...partitioning too

    A few weeks ago, I decided to become a man and install Ubuntu on my Sony Vaio laptop--dual-booting it with Windows XP (OK, half-a-man). After quite a few speedbumps, it got installed, and I've been using it happily since...well, not quite.
    I have a 40 GB ATA hard drive (let me know if you want to know more--that's all I know off the top of my head), which came partitioned in C:\ and D:\.
    After installing Ubuntu, C:\ was left intact (FYI-it has Windows on it), and D:\ was wiped, reformatted into Ext3, and had Ubuntu installed. I also made a one gig swap partition (while we're here--is that a good size?). D:\ is about 19 GBs big, and it previously had a lot of Windows-specific Program Files on it. I didn't know how big to make it when installing Ubuntu, so I just kept it at 19-odd, and now have no space for my Program Files.
    So today, using Windows (that was the first tutorial I found online), I cut it down a bit, and used the "unallocated space" to make an NTFS partition. I continued about my business, and eventually shut down. Then I tried to reboot and...Grub 1.5 loading...Error 17.
    So I whipped out the Ubuntu live CD (I do NOT have the Windows one), used the "try" feauture to get help, ended up re-installing GRUB, rebooted, and got the OS selection screen.
    ==Now the problems start==
    * There are TWO Ubuntu 8.04/Ubuntu 8.04 recovery mode entires apiece.
    * When I try to enter Ubuntu/recovery mode/the other Ubuntu/ the other recovery mode/memtest (only one of those), it gives me Error 17, and says it can't mount the partition.
    * When I try to enter Windows XP, it gives me Error 22, and says there is "no partition" (Direct quote) (?????)
    ==End problems==
    So here I am running Ubuntu off a CD, and am at my wit's end, having Googled everything I can think of.
    I can post more info if you want, I'm just not sure what you do want...(I'm still a bit new at this)

    I've been to and did this:
    1. Boot from a Live CD, like Ubuntu Live, Knoppix, Mepis, or similar.

    2. Open a Terminal. Go SuperUser (that is, type "su"). Enter root passwords as necessary.

    3. Type "grub" which makes a GRUB prompt appear.

    4. Type "find /boot/grub/stage1". You'll get a response like "(hd0)" or in my case "(hd0,3)". Use whatever your computer spits out for the following lines.

    5. Type "root (hd0,3)".

    6. Type "setup (hd0,3)". This is key. Other instructions say to use "(hd0)", and that's fine if you want to write GRUB to the MBR. If you want to write it to your linux root partition, then you want the number after the comma, such as "(hd0,3)".

    7. Type "quit".

    8. Restart the system. Remove the bootable CD.
    And it did nothing.
    And I HAVEN'T done this:
    1. Boot your computer up with Ubunto CD
    2. Go through all the process until you reech "[!!!] Disk Partition"
    3. Select Manual Partition
    4. Mount your appropriate linux partions


    6. Finish the manual partition
    7. Say "Yes" when it asks you to save the changes
    8. It will give you errors saying that "the system couldn't install ....." after that
    9. Ignore them, keep select "continue" until you get back to the Ubuntu installation menu
    10. Jump to "Install Grub ...."
    because I've never seen [!!!] Disk Partition.
    Last edited by fiddler616; July 4th, 2008 at 09:52 PM. Reason: Wrong copy&paste

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts