Results 1 to 2 of 2

Thread: [SOLVED] Problems with Atheros wireless notebook adapter

  1. #1
    Join Date
    Aug 2008

    [SOLVED] Problems with Atheros wireless notebook adapter


    I have a laptop with a wireless (built in) network controller (intel). However I bought a Linksys WPC300N Notebook adapter.

    If I run "lspci -v | grep Atheros" I get

    16:00.0 Network controller: Atheros Communications Inc. AR5416 802.11abgn Wireless PCI Adapter (rev 01)

    Thus I know that Ubuntu (8.04) did find the card. However if I do

    ifconfig or iwconfig no ath0 is available.

    I tried following some threads about installing "madwifi" but still no luck. By the way: The reason why I which to use my Linksys adapter instead of the buildin "Intel" is that I need to be able to change to "monitor mode"

    I hope that you have some helpful thoughts.....
    Last edited by clausjuhl; August 15th, 2008 at 10:47 PM. Reason: error in subject: It is not a PCI card but a laptop adapter card

  2. #2
    Join Date
    Aug 2008

    Re: Atheros AR5416 not detected in iwconfigr

    I am running ubuntu 8.04 on a lenovo T60.

    just to provide some basic results: iwconfig returns

    lo no wireless extensions.

    irda0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"....." Nickname:""
    Mode:Managed Frequency:2.427 GHz Access Point: 00:1D:7E:AB:B2:9A
    Bit Rate=54 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2346 B
    Encryption key:"........" (changed when copying the text)
    Power Managementff
    Link Quality=84/100 Signal level=-50 dBm Noise level=-84 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    Last edited by clausjuhl; August 15th, 2008 at 10:48 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts