Results 1 to 4 of 4

Thread: trouble with second hard drive; cant change owner

  1. #1
    Join Date
    Jun 2008
    Beans
    11

    trouble with second hard drive; cant change owner

    When I go to permissions and change the owner right after I click my name the window closes. If you need anymore info just tell me.

  2. #2
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: trouble with second hard drive; cant change owner

    fat, ntfs, ext2 or ext3?
    internal/external?
    Last edited by sisco311; July 3rd, 2008 at 10:33 PM.

  3. #3
    Join Date
    Jun 2008
    Beans
    11

    Re: trouble with second hard drive; cant change owner

    fat32, internal

  4. #4
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: trouble with second hard drive; cant change owner

    You can't change the owner and permissions on fat and ntfs partitions.

    You can setup the permissions and owner at mount time.
    Open a terminal and list the partitions:
    Code:
    sudo fdisk -l
    ...
    /dev/sdXY ... ... FAT32
    ...

    sdXY is the fat partition.
    To setup the permissions you need to create a new enrty in the fstab
    (or modify the old entry if exist)

    First get the uuid of the partition:
    Code:
    sudo vol_id --uuid /dev/sdXY
    edit the fstab:
    Code:
    gksu gedit /etc/fstab
    and add this line:
    UUID=<copy the uuid of the partition here> /media/<mount-point> vfat defaults,umask=002,gid=46 0 0
    umask=002 sets the permission to 775(read/write/execute for owner, read/write/execute for group, read/execute for others)
    gid=46 sets the group id to 46(plugdev)

    By default, the user created during the install is member of the group plugdev(46).

    If you want, you can set the owner(by default is root) with the uid option:
    uid=your-user-name

    For more info about permissions:
    https://help.ubuntu.com/community/FilePermissions

    For more mount options read the manual page:
    Code:
    man mount
    (q to quit)

    create the <mount point> (a directory in your filesystem where you can access the partition)
    Code:
    sudo mkdir /media/<mount-point>
    replace <mount-point> with a directory name (disk, music, windows ... )

    mount the partition:
    Code:
    sudo mount -a

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •