Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Wine Programs Can't Detect Mounted .iso

  1. #11
    Join Date
    Mar 2012
    Beans
    5

    Re: Wine Programs Can't Detect Mounted .iso

    This didn't work for me, I followed all the instructions here.

    Here is what comes up when I type ls -l while in ~/.wine/dosdevices

    Code:
    lrwxrwxrwx 1 david david 14 2012-03-15 13:40 a: -> /media/floppy0
    lrwxrwxrwx 1 david david  8 2012-03-15 13:40 b:: -> /dev/fd0
    lrwxrwxrwx 1 david david 10 2012-03-15 13:21 c: -> ../drive_c
    lrwxrwxrwx 1 david david 14 2012-03-15 13:41 e: -> /media/rebirth
    lrwxrwxrwx 1 david david 10 2012-03-15 13:21 e:: -> /dev/loop0
    lrwxrwxrwx 1 david david 11 2012-03-15 13:40 h: -> /home/david
    lrwxrwxrwx 1 david david  1 2012-03-15 13:21 z: -> /
    rebirth installed fine, but I still get the waiting for cd message when I start it up.

    thanks a lot

  2. #12
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Wine Programs Can't Detect Mounted .iso

    Hello and welcome to the forums polarcheese.

    Try removing the /dev/loop0 entry and linking directly to the iso:
    Code:
    rm ~/.wine/dosdevices/e\:\:
    ln -s /path/to/rebirth.iso ~/.wine/dosdevices/e\:\:

  3. #13
    Join Date
    Mar 2012
    Beans
    5

    Re: Wine Programs Can't Detect Mounted .iso

    Thanks for the reply, I tried your fix, but unfortunately I still get the same error about needing the cd.

    when I type ls -l while in ~/.wine/dosdevices now this is what it looks like:
    Code:
    lrwxrwxrwx 1 david david 14 2012-03-15 13:40 a: -> /media/floppy0
    lrwxrwxrwx 1 david david  8 2012-03-15 13:40 b:: -> /dev/fd0
    lrwxrwxrwx 1 david david 10 2012-03-15 13:21 c: -> ../drive_c
    lrwxrwxrwx 1 david david  8 2012-03-15 18:13 d:: -> /dev/sr0
    lrwxrwxrwx 1 david david 14 2012-03-15 13:41 e: -> /media/rebirth
    lrwxrwxrwx 1 david david 20 2012-03-20 12:56 e:: -> /path/to/rebirth.iso
    lrwxrwxrwx 1 david david 14 2012-03-20 12:57 f: -> /media/rebirth
    lrwxrwxrwx 1 david david 10 2012-03-20 12:57 f:: -> /dev/loop0
    lrwxrwxrwx 1 david david 11 2012-03-15 13:40 h: -> /home/david
    lrwxrwxrwx 1 david david  1 2012-03-15 13:21 z: -> /
    The line highlighted in red above is also red in the terminal.

    If it helps I'm running ubuntu 11.10 with wine 1.4 rc2

    thanks again.

  4. #14
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Wine Programs Can't Detect Mounted .iso

    lrwxrwxrwx 1 david david 20 2012-03-20 12:56 e:: -> /path/to/rebirth.iso
    You need to change "/path/to" to be the actual path to the iso file. So, if your iso file is in your home directory and it is called rebirth.iso, it should read:
    Code:
    lrwxrwxrwx 1 david david 20 2012-03-20 12:56 e:: -> /home/david/rebirth.iso

  5. #15
    Join Date
    Mar 2012
    Beans
    5

    Re: Wine Programs Can't Detect Mounted .iso

    Thanks so much, that was really silly of me.

    how would I change the path now that I have already linked it to the wrong place? Do I need to remove the old link?

    thanks again

  6. #16
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Wine Programs Can't Detect Mounted .iso

    Yes, remove the existing link:
    Code:
    rm ~/.wine/dosdevices/e\:\:

  7. #17
    Join Date
    Mar 2012
    Beans
    5

    Re: Wine Programs Can't Detect Mounted .iso

    Unfortunately that has still not solved the problem, when I type ls -l I now see:

    Code:
    lrwxrwxrwx 1 david david 14 2012-03-15 13:40 a: -> /media/floppy0
    lrwxrwxrwx 1 david david  8 2012-03-15 13:40 b:: -> /dev/fd0
    lrwxrwxrwx 1 david david 10 2012-03-15 13:21 c: -> ../drive_c
    lrwxrwxrwx 1 david david  8 2012-03-15 18:13 d:: -> /dev/sr0
    lrwxrwxrwx 1 david david 14 2012-03-15 13:41 e: -> /media/rebirth
    lrwxrwxrwx 1 david david 50 2012-03-21 10:34 e:: -> /home/david/downloads/rebirth_iso_installation.iso
    lrwxrwxrwx 1 david david 14 2012-03-20 12:57 f: -> /media/rebirth
    lrwxrwxrwx 1 david david 10 2012-03-20 12:57 f:: -> /dev/loop0
    lrwxrwxrwx 1 david david 11 2012-03-15 13:40 h: -> /home/david
    lrwxrwxrwx 1 david david  1 2012-03-15 13:21 z: -> /

  8. #18
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Wine Programs Can't Detect Mounted .iso

    Hmmmm. Try removing the 2 f: drive links. Maybe they're interfering:
    Code:
    rm ~/.wine/dosdevices/f\:
    rm ~/.wine/dosdevices/f\:\:
    Also, what command/how are you starting the installation process?

  9. #19
    Join Date
    Mar 2012
    Beans
    5

    Re: Wine Programs Can't Detect Mounted .iso

    Still no luck.

    To start the program I'm double clicking the desktop icon created during installation.

  10. #20
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Wine Programs Can't Detect Mounted .iso

    Quote Originally Posted by polarcheese View Post
    Still no luck.

    To start the program I'm double clicking the desktop icon created during installation.
    Instead, try running the installation program like this:
    Code:
    wine "f:\Setup.exe"
    ...assuming that Setup.exe is the name of the installation setup file.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •