Results 1 to 7 of 7

Thread: No sound in Javva

Threaded View

  1. #1
    Join Date
    Apr 2008
    Beans
    17
    Distro
    Kubuntu 8.04 Hardy Heron

    No sound in Javva

    Previously I was able to access Java applets across the web with sound, but for some reason it has stopped working. I have installed Java by Sun Microsystems from the Ubuntu repository (including JRE, packages "sun-java6-bin" and "sun-java6-jre"). I have reinstalled the packages, but with no success. Sometimes the sound will load but the applet will not ("applet bail"). I have only used Java on the MMORPG "RuneScape". The graphics usually load, but now the sound doesn't, other times the applet only displays as a grey-coloured box. (I am using Mozilla Firefox, Java is enabled).

    Browser + Version: Mozilla Firefox 3.0
    OS: Hardy (Kubuntu) with KDE 3.5.9 (I do have KDE 4, but it has other issues that cause it to be unusable).

    I have tried restarting the sound system, but the sound works OK in the desktop environment, but not in any Java applets. (It does work with Adobe Flash).

    I have not tested icedtea Java.

    java -version
    yields:

    java version "1.6.0_06"
    Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
    Java HotSpot(TM) Client VM (build 10.0-b22, mixed mode, sharing)
    I have heard the VM (Virtual Machine) does not work well in Ubuntu, but I have found no official response. Any workarounds for this? Note: It had been working before I restarted my computer. (After a power failure, but I believe this to be irrelevant). Graphics and sound had been working before, and occasionally the graphics do not load, although the sound had, now, sometimes the graphics do not load, (there's still no sound), or only the graphics load in the applet (Java's problems can be a nuisance). Would the solution be to use a different compiler/runtime environment/virtual machine? Or is there something else that needs done? Thanks to anyone who can help me, this is rather a depriving situation. (I hope this is not an exact duplicate, I could not find any threads that helped, and I hope this is in the correct category).

    Thanks

    EDIT: Sorry about the misspelling in the title
    Last edited by PseudoOne; June 29th, 2008 at 04:13 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •