Results 1 to 1 of 1

Thread: Ubuntu and IBM R40 - several problems

  1. #1
    Join Date
    Jun 2008
    Beans
    1

    Ubuntu and IBM R40 - several problems

    I am new to Linux and have installed Ubuntu 8.04 on an IBM ThinkPad R40. I am having several problems.

    1) The IBM R40 has the ATI/Radeon 7500 video card, which is supposed to be supported by drivers in X11. However, my X11org.cong file does not list the ATI/Radeon card or driver.

    The entire contents of the X11org.conf file are listed below.
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Synaptics Touchpad"
    EndSection
    Yet, when I do "lshw" from the terminal, the following is listed under display
    -display UNCLAIMED
    description: VGA compatible controller
    product: Radeon Mobility M7 LW [Radeon Mobility 7500]
    vendor: ATI Technologies Inc
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 00
    width: 32 bits
    clock: 66MHz
    capabilities: agp agp-2.0 pm vga_controller bus_master cap_list
    configuration: latency=66 mingnt=8
    When I go to Screen Resolution, there are three basic settings, 640x480, 800x600, 1024x768 all at 60hz. I am sure that the ATI/Radeon 7500 supports more resolutions that this.

    2)Ubuntu does not recognise my Belkin F5D7010 (ver 5000) wireless PCMCIA card. The only recongition I get is when I run pccardctl status (with the card in the slot) it returns
    Socket 0:
    3.3V 32-bit PC Card
    pccardctl ident yields the following:
    Socket 0:
    no product info available
    pccardctl info yields:
    PRODID_1=""
    PRODID_2=""
    PRODID_3=""
    PRODID_4=""
    MANFID=0000,0000
    FUNCID=255
    lshw yields:
    *-pcmcia
    description: CardBus bridge
    product: PCI1510 PC card Cardbus Controller
    vendor: Texas Instruments
    physical id: 0
    bus info: pci@0000:02:00.0
    version: 00
    width: 32 bits
    clock: 33MHz
    capabilities: pcmcia bus_master cap_list
    configuration: driver=yenta_cardbus latency=176 maxlatency=5 module=yenta_socket
    I have installed the ndisgtsk package to run ndiswrapper from a GUI interface. It will not load the Belkin .inf file that I copied from the Belkin install Cd or a copy of Windows 2K, where the card has worked. It keeps telling me that the BLKWGN.INF file is invalid. I tried running ndiswrapper from terminal but still no success. I know the card works and according to documentation in the Ubuntu forums, it should work out of box with Ubuntu.

    3) Ubuntu does not recognize the sound card. It keeps telling me that there are no GStreamer or plugins and/or device found. I have changed settings in the sound preferences and none of them work. I have looked in package manager and there are several GStreamer packages already installed.

    Thank you in advance for your assistance.
    Last edited by pvtwillis; June 29th, 2008 at 03:21 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •