Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: gnome-panel jammed

  1. #1
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    gnome-panel jammed

    Had a crash and gnome-panel has been badly jammed up since. It takes several minutes to get any reaction from a selection. Other apps are not affected, and I can't see the source of the slowdown in System Monitor. Have tried reinstalling gnome-panel via Synaptic, but no difference.

    Lacking a better idea I'm considering reinstalling Heron. I have a separate Home partition, so figuring formatting root and going fresh.

    Is there a better way? Like an overwrite install that simply corrects corrupted files?

  2. #2
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: gnome-panel jammed

    Maybe the configuration files of the panel are corrupted.
    Try to rename the config directory(~/.gconf/apps/panel) and let the system to set the default config files.

    After the directory is renamed type:
    Code:
    killall gnome-panel
    in a terminal. press Alt+F2 and type:
    Code:
    gnome-panel
    Note: this will restore (hopefully) the default panels. If this doesn't work just rename the directory to ~/.gconf/apps/panel.

  3. #3
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel jammed

    No luck.

    Renamed as /panelBAK. Running 'killall gnome-panel' refreshed the existing panel. Alt+F2 'gnome-panel' did nothing visible. No new /panel directory was created. Rebooted and waited about ten minutes for any panel to show up. Having none, I checked and found there was a new /panel dir now, deleted that and renamed the old one back.

    Rebooted, and back to my original jammed up panel.

  4. #4
    Join Date
    Apr 2008
    Location
    USA
    Beans
    225
    Distro
    Ubuntu 9.10 Karmic Koala

    Post Re: gnome-panel jammed

    I just found a website for fixing messed up gnome-panel's. You can check it out as I really don't know if it applies to the problem you are having:

    http://www.watchingthenet.com/restor...-settings.html

  5. #5
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: gnome-panel jammed

    On your terminal, Try this:

    Code:
    sudo gconftool-2 --shutdown
    sudo rm -rf ~/.gconf/panel
    sudo pkill gnome-panel
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  6. #6
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel jammed

    iaculallad, i think you meant 'sudo rm -rf ~/.gconf/apps/panel'? That would be the same as AndThenWhat's link. It is for restoring the default panel configuration.

    (People reading along are advised to back up their current ~/.gconf/apps/panel if they want the option of returning to it after that procedure.)

    Okay, have done this, which is essentially the same as sisco311's advice, with the same result: no panels on reboot. After five minutes i restored my backup, & rebooted back to the jammed version. Opening the first menu takes seven minutes.

    So now we know it has nothing to do with user config. Is there a way to kill the panel and then start it again in terminal? If we can see the output during that seven minutes, we may have the culprit.
    Last edited by ofb; June 21st, 2008 at 05:19 AM. Reason: (I can't spell.)

  7. #7
    Join Date
    Mar 2008
    Location
    City of Pines
    Beans
    3,585

    Re: gnome-panel jammed

    Quote Originally Posted by ofb View Post
    iaculallad, i think you meant 'sudo rm -rf ~/.gconf/apps/panel'? That would be the same as AndThenWhat's link. It is for restoring the default panel configuration.

    (People reading along are advised to back up their current ~/.gconf/apps/panel if they want the option of returning to it after that procedure.)

    Okay, have done this, which is essentially the same as sisco311's advice, with the same result: no panels on reboot. After five minutes i restored my backup, & rebooted back to the jammed version. Opening the first menu takes seven minutes.

    So now we know it has nothing to do with user config. Is there a way to kill the panel and then start it again in terminal? If we can see the output during that seven minutes, we may have the culprit.
    My mistake, that should be sudo rm -rf ~/.gconf/apps/panel. Another way to do a reset is to create another user, logout from your current user account and log back in using the newly created account. Copy the values of ~/.gconf/apps/panel to your account, overwritting it.
    Steady movement is more important than speed, much of the time. So long as there is a regular progression of Stimuli to get your mental hooks into, there is room for lateral movement. Once this begins, its rate is a matter of discretion.

  8. #8
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel jammed

    Gnome-panel works in the new account. With that configuration imported to my account, it took about ten minutes before the panels appeared. Reverting to original panel config, I get the panel on login but there's a seven minute delay before it recognizes the first click.

    So the problem is not in that directory, but it is on the user side, and reinstalling without wiping /home probably won't fix what's wrong. Sound right?

  9. #9
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel jammed

    There are other consistent delays when I try to do Gnome related things. Here are some terminal outputs.

    Code:
    o@redfish:~$ opera  -notrayicon -nomail
    ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
    Those lines are normal for Opera on start-up. Now ctrl-click an image to Save As,

    Code:
    (<unknown>:6884): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/o/.recently-used.xbel', but the parser failed: Error reading file '/home/o/.recently-used.xbel': Is a directory.
    
    (<unknown>:6884): GLib-CRITICAL **: g_bookmark_file_get_size: assertion `bookmark != NULL' failed
    There is a consistent 25 second jam before the Gnome Save dialog comes up. Now save the image and you get,

    Code:
    (<unknown>:6884): Gtk-WARNING **: Attempting to store changes into `/home/o/.recently-used.xbel', but failed: Failed to rename file '/home/o/.recently-used.xbel.V3BVCU' to '/home/o/.recently-used.xbel': g_rename() failed: Is a directory
    Note that the operation succeeds, we simply have a jammed computer during it. This happens for every Save in Opera -- images, PDF, whatever.

    Similar, there is a 50 second jam when we select Save for the first time for a Gedit document. In terminal,

    Code:
    o@redfish:~$ gedit
    
    (gedit:7024): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/o/.recently-used.xbel', but the parser failed: Error reading file '/home/o/.recently-used.xbel': Is a directory.
    
    (gedit:7024): GLib-CRITICAL **: g_bookmark_file_get_size: assertion `bookmark != NULL' failed
    Those lines are not normal. Gedit should simply open after the command.

    Enter some text and hit Save, get a 50 sec delay, get the Save dialog, hit Save.

    Code:
    sys:1: GtkWarning: Attempting to store changes into `/home/o/.recently-used.xbel', but failed: Failed to rename file '/home/o/.recently-used.xbel.XPTWCU' to '/home/o/.recently-used.xbel': g_rename() failed: Is a directory
    Close gedit,

    Code:
    sys:1: GtkWarning: Attempting to store changes into `/home/o/.recently-used.xbel', but failed: Failed to rename file '/home/o/.recently-used.xbel.06R7CU' to '/home/o/.recently-used.xbel': g_rename() failed: Is a directory

  10. #10
    Join Date
    Mar 2007
    Beans
    519
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gnome-panel jammed

    Well, poop. That's all unrelated. It's just noise from .recently-used.xbel being made a directory to get rid of Places > Recent Documents. Restore that to default and I still have all the Gnome jams and no related terminal outputs to tell me why.

    Is there another way to find out what the machine is hanging on?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •