Results 1 to 8 of 8

Thread: autostart conky and wicd in fluxbox

  1. #1
    Join Date
    Apr 2008
    Beans
    22
    Distro
    Xubuntu 8.04 Hardy Heron

    Angry autostart conky and wicd in fluxbox

    I've been trying to get conky and wicd to start on startup in fluxbox. Wicd doesn't bother me that much, but I would like conky to start automatically when I startup. I tried putting

    conky &

    in the /.fluxbox/startup file, and it worked with netapplet in the same way, with

    netapplet &

    Neither of them worked.

    Next I tried making a autostart.sh file with:

    #!/bin/bash
    sleep 5 && conky;

    And I made it executable with chmod a+x and it doesn't work. I'm stumped, because it worked with netapplet in the startup file. I did put in the init file the sh /home/*/.fluxbox/autostart.sh in

    session.screen0.rootCommand: sh /home/*/.fluxbox/autostart.sh

    I'm going to keep trying. I've tried every way I could find here on the forums. Please help!

    Running Xubuntu 8.04 with fluxbox installed. I prefer fluxbox to Xfce.

  2. #2
    Join Date
    May 2007
    Location
    Crete, Greece
    Beans
    582

    Re: autostart conky and wicd in fluxbox

    This is my .startup file and conky starts just fine, no problems at all.
    Code:
    # fluxbox startup-script:
    #
    # Lines starting with a '#' are ignored.
    
    # You can set your favourite wallpaper here if you don't want
    # to do it from your style.
    #
    
    #fbsetbg -f /media/sdb1/Pictures/WallPapers/download.jpg
    #
    # This sets a black background
    
    /usr/bin/fbsetroot -solid black
    
    # This shows the fluxbox-splash-screen
    # fbsetbg -C /usr/share/fluxbox/splash.jpg
    
    # Other examples. Check man xset for details.
    #
    # Turn off beeps:
    # xset -b
    #
    # Increase the keyboard repeat-rate:
    # xset r rate 195 35
    #
    # Your own fonts-dir:
    # xset +fp "/home/jorge/.fonts"
    #
    # Your favourite mouse cursor:
    # xsetroot -cursor_name right_ptr
    #
    # Change your keymap:
    # xmodmap "/home/jorge/.Xmodmap"
    
    
    
    # Applications you want to run with fluxbox.
    # MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
    #
    # unclutter -idle 2 &
    # wmnd &
    # wmsmixer -w &
    # idesk &
    
    conky &
    klipper &
    
    
    # And last but not least we start fluxbox.
    # Because it is the last app you have to run it with ''exec'' before it.
    
    exec /usr/bin/fluxbox
    # or if you want to keep a log:
    # exec /usr/bin/fluxbox -log "/home/jorge/.fluxbox/log"
    Maybe you put it in the wrong line?

  3. #3
    Join Date
    Jul 2006
    Location
    Here
    Beans
    10,543

    Re: autostart conky and wicd in fluxbox

    try in your ~/.fluxbox/startup:
    sleep 5;conky &

  4. #4
    Join Date
    May 2007
    Location
    Colorado
    Beans
    Hidden!

    Re: autostart conky and wicd in fluxbox

    Or:

    (sleep 3 && conky) &

  5. #5
    Join Date
    Feb 2007
    Location
    Macedonia, Greece
    Beans
    151
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: autostart conky and wicd in fluxbox

    What about:
    conky -d


    You don't need to use &, cause with -d option, conky runs as a deamon.
    ARIS: Empire strikes back...

  6. #6
    Join Date
    Apr 2008
    Beans
    22
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: autostart conky and wicd in fluxbox

    Unfortunately, nothing has worked. Please help me, it's really starting to annoy me.

  7. #7
    Join Date
    Aug 2010
    Beans
    7

    Re: autostart conky and wicd in fluxbox

    I know this is an old thread but I had the same problem, only with Xubuntu 10.04, and thought that if two people had the same problem two years apart then maybe more people might.

    I had set up conky and networking to autostart in Xfce and tried to get the same in Fluxbox using every solution suggested here and many more,with no success, but it would start and run when I started it in a terminal even if I closed the terminal.

    Finally I removed Xfce and xfwm ( it was using 50% more RAM to do the same job ) as soon as I did and rebooted conky and network autostarted and has worked since.



    Jeff

  8. #8
    Join Date
    Jul 2008
    Beans
    3

    Re: autostart conky and wicd in fluxbox

    Quote Originally Posted by kerry_s View Post
    try in your ~/.fluxbox/startup:
    sleep 5;conky &
    This worked for me!
    I've just changed the "...conky &" for the "...conky -d &"



    PS: Sleep 5s is too much! :S

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •