Results 1 to 6 of 6

Thread: VSFTPD keeps giving me 550 Permission Denied

  1. #1
    Join Date
    Jun 2008
    Beans
    1

    VSFTPD keeps giving me 550 Permission Denied

    I just installed VSFTPD and made a user named ftpadmin.
    I made the home folder for ftpadmin /var/www
    I also gave ftpadmin ownership of /var/www

    No matter what I do, I can't delete, add, or do anything in any directory even though when I log in, it goes there.

    What am I doing wrong?

    Thanks,
    cmetcjr

  2. #2
    Join Date
    Oct 2007
    Beans
    81

    Re: VSFTPD keeps giving me 550 Permission Denied

    am I correct in assuming you created vsftpadmin user and are logging into the FTP server using that account? As opposed to that being the user the server daemon is running as.

    Whichever account you use to login to the server is going to need permissions to the folders you are giong to browse.

    You mention you've set the ownership on the folder, can you confirm the permissions with a screenie/dump?

    I used
    sudo chown -R ftpadmin /var/www
    sudo chmod -R 777 /var/www

    watch out for the last line though, as this gives all users full access to the folder. But it's a good starting point, because it should allow access, and then you can start locking it down.

  3. #3
    Join Date
    Jan 2009
    Beans
    13

    Re: VSFTPD keeps giving me 550 Permission Denied

    Well I also had a similar problem .. i figured out the solution.

    open your vsftpd.conf file .. for me it was in /etc/vsftpd.conf.

    There you will find the following line :
    # Uncomment this to enable any form of FTP write command.
    #write_enable=YES

    Uncomment this .. it will look like this.
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES

    Restart your ftp daemon and I hope things will work as expected.

    Cheers !!!!
    www.sangeek.com

  4. #4
    Join Date
    Mar 2011
    Beans
    1

    Thumbs up Re: VSFTPD keeps giving me 550 Permission Denied

    Quote Originally Posted by k.sangeeth View Post
    Well I also had a similar problem .. i figured out the solution.

    open your vsftpd.conf file .. for me it was in /etc/vsftpd.conf.

    There you will find the following line :
    # Uncomment this to enable any form of FTP write command.
    #write_enable=YES

    Uncomment this .. it will look like this.
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES

    Restart your ftp daemon and I hope things will work as expected.

    Cheers !!!!
    www.sangeek.com
    Thanks for your answer. It's helped.
    After uncommend this line I used following command to restart FTP server:
    Code:
    service vsftpd restart
    Last edited by pablobablo; March 12th, 2011 at 08:37 PM.

  5. #5
    Join Date
    Jun 2007
    Beans
    31

    Re: VSFTPD keeps giving me 550 Permission Denied

    I have the same issue, BUT when I try to access cd / etc/vsftpd.comf I get
    -bash cd / etc/vsftpd.comf :Not a directory

    Help please

  6. #6
    Join Date
    Aug 2008
    Location
    Victoria, BC Canada
    Beans
    1,741

    Re: VSFTPD keeps giving me 550 Permission Denied

    open a terminal

    Code:
    sudo nano /etc/vsftpd.conf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •