Results 1 to 5 of 5

Thread: Mplayert, VLC, etc. won't output through USB audio

  1. #1
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    310
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Mplayert, VLC, etc. won't output through USB audio

    I've got a Turtle Beach USB sound card that Amarok and the system output sound through fine, but for whatever reason I can't configure either of these media players to use this USB output. Does anyone have any tips?
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

  2. #2
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    310
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Mplayert, VLC, etc. won't output through USB audio

    As an update, Firefox 3 doesn't work either. They all try to route through the onboard sound. I'm going to try some other things and post back my results.
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

  3. #3
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    310
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Mplayert, VLC, etc. won't output through USB audio

    Tried editing modprobe.d/alsa-base but it didn't change anything.
    Last edited by djbon2112; June 19th, 2008 at 04:54 PM.
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

  4. #4
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    310
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Mplayert, VLC, etc. won't output through USB audio

    HELP Alright I restarted and now I can't even get the USB audio anymore! At first it said "USB Audio (Disconnected)" but now it doesn't even show anything! The card shows up with lsusb but not cat /proc/asound/cards

    EDIT: Alright I fixed it, it was because I tried to give that card spot 0 in alsa-base, but there's still gotta be a way to make this card the default for linux, instead of my onboard. Any suggestions? Please?
    Last edited by djbon2112; June 19th, 2008 at 04:58 PM.
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

  5. #5
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mplayert, VLC, etc. won't output through USB audio

    You should be able to select it in System/Prefences/Sound or Mutimedia Systems Selector. If you are using alsa and not pulseaudio you can get:

    asoundconf-gtk (choose default alsa sound card)

    and use that to select your sound card.

    I had all sorts of problems with my two sound cards and pulseaudio so I disabled pulseaudio and got all the alsa plugins and wrappers and utilities, etc and now have a pure alsa setup that works great for everything, all the time, through numerous kernel updates etc. rock solid.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •